aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/dvdbackup/10-dvdbackup-dvdread-6.1.patch90
-rw-r--r--testing/dvdbackup/APKBUILD32
2 files changed, 122 insertions, 0 deletions
diff --git a/testing/dvdbackup/10-dvdbackup-dvdread-6.1.patch b/testing/dvdbackup/10-dvdbackup-dvdread-6.1.patch
new file mode 100644
index 00000000000..d239600cbc2
--- /dev/null
+++ b/testing/dvdbackup/10-dvdbackup-dvdread-6.1.patch
@@ -0,0 +1,90 @@
+Author: Nicolas Porcel - taken from voidlinux
+Summary: fixes for musl
+----
+--- a/src/dvdbackup.c
++++ b/src/dvdbackup.c
+@@ -1132,7 +1132,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ int size;
+
+ /* DVD handler */
+- ifo_handle_t* ifo_file = NULL;
++ dvd_file_t* ifo_file = NULL;
+
+ if (title_set_info->number_of_title_sets + 1 < title_set) {
+ return(1);
+@@ -1181,7 +1181,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_ifo = open(targetname_ifo, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_ifo);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1191,7 +1191,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_bup = open(targetname_bup, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_bup);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1200,31 +1200,31 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ /* Copy VIDEO_TS.IFO, since it's a small file try to copy it in one shot */
+
+- if ((ifo_file = ifoOpen(dvd, title_set))== 0) {
++ if ((ifo_file = DVDOpenFile(dvd, title_set, DVD_READ_INFO_FILE))== 0) {
+ fprintf(stderr, _("Failed opening IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- size = DVDFileSize(ifo_file->file) * DVD_VIDEO_LB_LEN;
++ size = DVDFileSize(ifo_file) * DVD_VIDEO_LB_LEN;
+
+ if ((buffer = (unsigned char *)malloc(size * sizeof(unsigned char))) == NULL) {
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- DVDFileSeek(ifo_file->file, 0);
++ DVDFileSeek(ifo_file, 0);
+
+- if (DVDReadBytes(ifo_file->file,buffer,size) != size) {
++ if (DVDReadBytes(ifo_file,buffer,size) != size) {
+ fprintf(stderr, _("Error reading IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1234,7 +1234,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_ifo,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_ifo);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1243,7 +1243,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_bup,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_bup);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+-----
diff --git a/testing/dvdbackup/APKBUILD b/testing/dvdbackup/APKBUILD
new file mode 100644
index 00000000000..abb01c100c4
--- /dev/null
+++ b/testing/dvdbackup/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Sean McAvoy <seanmcavoy@gmail.com>
+# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
+pkgname=dvdbackup
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Tool to rip video DVDs from the command line"
+url="http://dvdbackup.sourceforge.net/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="libdvdread-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://sourceforge.net/projects/dvdbackup/files/dvdbackup/dvdbackup-$pkgver/dvdbackup-$pkgver.tar.xz
+ 10-dvdbackup-dvdread-6.1.patch"
+
+prepare() {
+ update_config_guess
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/locale
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="df9abb2ca0b8a7cd7855ddff94dae249b06b2ec0ee42f3e9c53aa46aebd9885bdf26dacecbd4a20ff5f642ea10c0c64b811d25c23802c8a2b1489281900fbe0d dvdbackup-0.4.2.tar.xz
+31bfbc09facc5fa827ac8f788f379d6cc4f84c8c8a6e3dc11be9a28455020a58cf47d8393815f5b416968e131b47c71185a1dda6832ca22bb95d0b7dc07a0604 10-dvdbackup-dvdread-6.1.patch"