aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadi-import-wizard/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadi-import-wizard/APKBUILD')
-rw-r--r--community/akonadi-import-wizard/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/akonadi-import-wizard/APKBUILD b/community/akonadi-import-wizard/APKBUILD
index 5f6cc858e00..a3f4aaaf714 100644
--- a/community/akonadi-import-wizard/APKBUILD
+++ b/community/akonadi-import-wizard/APKBUILD
@@ -1,16 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadi-import-wizard
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by kmailtransport -> libkgapi -> qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://kontact.kde.org/"
pkgdesc="Import data from other mail clients to KMail"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
- akonadi-dev>=$pkgver
+ akonadi-dev
extra-cmake-modules
kauth-dev
kconfig-dev
@@ -26,22 +29,23 @@ makedepends="
mailcommon-dev
messagelib-dev
pimcommon-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-import-wizard-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/akonadi-import-wizard.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-import-wizard-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -49,5 +53,5 @@ package() {
}
sha512sums="
-acf38642d8b35fca7cafcd7e55761d1928bfef23b61f1c1fca09c3b75624605fc9dd372aab5c0a203eed959c8e804d9e43595be676f4d3ceddd38bf7a0a72df0 akonadi-import-wizard-21.08.1.tar.xz
+2c46c3e23d10ff8a56418d5fe454ca543f2fc24f045f20dfe0eed45ace07ee7d04e4c6dc87e296fc71f2c1cb3f02b8f24d6ea5e883ba57da7c06b2a38543210b akonadi-import-wizard-24.02.2.tar.xz
"