aboutsummaryrefslogtreecommitdiffstats
path: root/community/ansible/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ansible/APKBUILD')
-rw-r--r--community/ansible/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/ansible/APKBUILD b/community/ansible/APKBUILD
index 6107faf3173..57a1c2fdb5d 100644
--- a/community/ansible/APKBUILD
+++ b/community/ansible/APKBUILD
@@ -1,17 +1,23 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Takuya Noguchi <takninnovationresearch@gmail.com>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=ansible
-pkgver=6.0.0
+pkgver=9.5.1
pkgrel=0
pkgdesc="core components for Ansible"
url="https://ansible.com/"
options="!check" # TODO: enable tests
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 ansible-core"
-makedepends="py3-setuptools"
+depends="python3 ansible-core>=2.16.0"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/a/ansible/ansible-$pkgver.tar.gz"
# secfixes:
@@ -21,13 +27,16 @@ source="https://pypi.python.org/packages/source/a/ansible/ansible-$pkgver.tar.gz
# - CVE-2020-25646
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-490bdc574ad6a444f8007138a12be5e5fcd8eb7abdd5466ff1924ac7c34e0a71be1c2495666ceefa1c88da48900fa2bca2c1e8d5775f3f559b1fa285bbcdcae9 ansible-6.0.0.tar.gz
+8a95f0e41987a1ab423ebd6be8483681c30f31dfd24056d729c4e0cc870775d3a59f9790bcd0bf578538ba24752b9dc6401fe467f4f8b12acdd50878555bc8c1 ansible-9.5.1.tar.gz
"