aboutsummaryrefslogtreecommitdiffstats
path: root/community/cffconvert/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cffconvert/APKBUILD')
-rw-r--r--community/cffconvert/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/cffconvert/APKBUILD b/community/cffconvert/APKBUILD
new file mode 100644
index 00000000000..6c7e9a4c945
--- /dev/null
+++ b/community/cffconvert/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=cffconvert
+pkgver=2.0.0
+pkgrel=6
+pkgdesc="Command line program to validate and convert CITATION.cff files"
+url="https://github.com/citation-file-format/cff-converter-python"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-click py3-jsonschema py3-pykwalify py3-requests py3-ruamel.yaml"
+checkdepends="py3-pytest"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver-2.tar.gz::https://github.com/citation-file-format/cff-converter-python/archive/$pkgver.tar.gz"
+builddir="$srcdir/cffconvert-$pkgver"
+options="!check" # a minor portion of tests are failing
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+e2fa31ae8b9426c61f794316e2cfe51ec55b3583e57f80d447950aa2b2d500056801b17c53da53d3520560f07f160dad7bf2111d58bbf236537abebc097984e6 cffconvert-2.0.0-2.tar.gz
+"