aboutsummaryrefslogtreecommitdiffstats
path: root/community/killbots/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/killbots/APKBUILD')
-rw-r--r--community/killbots/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/killbots/APKBUILD b/community/killbots/APKBUILD
index a3feaa89bdf..bb4f351bf46 100644
--- a/community/killbots/APKBUILD
+++ b/community/killbots/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=killbots
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="A simple game of evading killer robots"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/killbots/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
@@ -22,12 +24,14 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/killbots-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/killbots.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/killbots-$pkgver.tar.xz"
+# No tests
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-71ef2050a5acc32965d3e7f6aed30c848657244dd333f42be1160e9ce90832f6e3464260dc26f7e11b8011f3764d93d9fa15c1e11ea796227d2cf05eb3de2480 killbots-22.04.3.tar.xz
+a17378932810f9bea90d3821c1d393c842f697b456bda533135c628728111391ee34bbfd1a40d5b285e366e6bfc003600f80d0f8de616416be4447c7c40c6150 killbots-24.02.2.tar.xz
"