aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-linotify/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-linotify/makefile.patch')
-rw-r--r--community/lua-linotify/makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/lua-linotify/makefile.patch b/community/lua-linotify/makefile.patch
new file mode 100644
index 00000000000..d6131331b39
--- /dev/null
+++ b/community/lua-linotify/makefile.patch
@@ -0,0 +1,25 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -7,19 +7,13 @@
+ # out this line when debugging.
+ OMIT_FRAME_POINTER = -fomit-frame-pointer
+
+-# Seach for lua .pc file
+-LUAPKG_CMD = $(shell pkg-config --list-all | grep Lua | awk 'FNR == 1 {print $$1}')
+-CFLAGS = -fPIC -O3 -Wall $(shell pkg-config "$(LUAPKG_CMD)" --cflags)
+-LFLAGS = -shared $(OMIT_FRAME_POINTER)
+-INSTALL_PATH = $(shell pkg-config "$(LUAPKG_CMD)" --variable=INSTALL_CMOD)
+-
+ ## If your system doesn't have pkg-config, comment out the previous
+ ## lines and uncomment and change the following ones according to your
+ ## building enviroment.
+
+-#CFLAGS = -I/usr/include/lua5.1/ -fPIC -O3 -Wall
+-#LFLAGS = -shared $(OMIT_FRAME_POINTER)
+-#INSTALL_PATH = /usr/lib/lua/5.1
++CFLAGS = -I/usr/include/lua$(LUAVER)/ -fPIC -O3 -Wall
++LFLAGS = -shared $(OMIT_FRAME_POINTER)
++INSTALL_PATH = /usr/lib/lua/$(LUAVER)
+
+ all: $(LIBNAME)
+