aboutsummaryrefslogtreecommitdiffstats
path: root/community/nomad
diff options
context:
space:
mode:
Diffstat (limited to 'community/nomad')
-rw-r--r--community/nomad/APKBUILD75
-rw-r--r--community/nomad/nomad.confd1
-rw-r--r--community/nomad/nomad.initd38
-rw-r--r--community/nomad/nvidia-driver.patch21
-rw-r--r--community/nomad/server.hcl12
-rw-r--r--community/nomad/ui-remove-husky.patch43
6 files changed, 0 insertions, 190 deletions
diff --git a/community/nomad/APKBUILD b/community/nomad/APKBUILD
deleted file mode 100644
index ace754b063b..00000000000
--- a/community/nomad/APKBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
-# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
-# Contributor: omni <omni+alpine@hack.org>
-# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
-pkgname=nomad
-pkgver=1.1.1 # remember to update GIT_COMMIT below
-pkgrel=2
-pkgdesc="easy-to-use, flexible, and performant workload orchestrator"
-url="https://www.nomadproject.io/"
-arch="all !mips64 !riscv64 !x86"
-# x86 run out of memory, mips64 & riscv64 limited by yarn/npm
-license="MPL-2.0"
-depends="cni-plugins"
-makedepends="linux-headers bash make go yarn npm go-bindata-assetfs"
-subpackages="$pkgname-openrc"
-options="net !check" # cannot produce environment for testing in CI
-source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/nomad/archive/v$pkgver.tar.gz
- nomad.initd
- nomad.confd
- nvidia-driver.patch
- server.hcl
- ui-remove-husky.patch"
-
-# secfixes:
-# 1.1.1-r0:
-# - CVE-2021-32575
-# 1.0.4-r0:
-# - CVE-2021-3283
-# 0.12.7-r0:
-# - CVE-2020-28348
-# - CVE-2020-27195
-# 0.11.1-r0:
-# - CVE-2020-10944
-# 0.10.3-r0:
-# - CVE-2020-7218
-# 0.9.6-r0:
-# - CVE-2019-12741
-# - CVE-2019-15928
-# - CVE-2019-16742
-# 0.9.5-r0:
-# - CVE-2019-14802
-# - CVE-2019-14803
-# 0.9.2-r0:
-# - CVE-2019-12618
-
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GIT_COMMIT="a6fab0f"
-
-build() {
- make ember-dist
- GO_TAGS="ui release" make static-assets
- go build -v -o bin/"$pkgname" \
- -ldflags "-X github.com/hashicorp/nomad/version.GitCommit='$pkgver'" \
- -tags "ui release"
-}
-
-check() {
- go test -timeout=15m "./..."
-}
-
-package() {
- install -m755 -D "$srcdir"/"$pkgname".initd "$pkgdir"/etc/init.d/"$pkgname"
- install -m644 -D "$srcdir"/"$pkgname".confd "$pkgdir"/etc/conf.d/"$pkgname"
-
- install -m755 -o root -g root -D bin/"$pkgname" "$pkgdir"/usr/sbin/"$pkgname"
- install -m640 -o root -g root -D "$srcdir"/server.hcl "$pkgdir"/etc/nomad.d/server.hcl
- install -m750 -o root -g root -d "$pkgdir"/var/lib/"$pkgname"
-}
-
-sha512sums="c039dd89e28337e6728da14b938bf2d23d48274c5893f0dc28a1de6a641decd6eec3923fc5970451cdb02c33edbf13389e12fd4a97df7e3068c2e7020502401b nomad-1.1.1.tar.gz
-ac969c81150ba57871c1f75f17c11d06ffc7bcc872882416c7c0d9d43f5e352ca1b7e7bfd75e32a9d01a826496c77a657dc298f5e048f85b4d9e85bc3afee51d nomad.initd
-a4fcc9f319926e8e5257dcc902cf3e1cbacd8bee82097b7a9719611d52037431a7e953a4b0fa90fc25475d2590cd14877c8e4c87bd909dd0099a754ba6f5063c nomad.confd
-e9c0161c2a9c0e1933c266520a410764a709c7b4f65b1a81c1fb2494eae89daa847ffca5df46d6eea61d855f35d21e66433ec0afe8c08017187c917e952b8544 nvidia-driver.patch
-c2ba7db5bb0858547bf346819945d24626ac761541f38350b40408e1b26227549f6aa4d6946baadbf856329c0ac9f81f84164597d11361224b62a1697f17e726 server.hcl
-ea2e1475cfe34d516ba55917ce0aa0410f70e450a9943ce2a78978235213811d3159bfcd8f1ba6051a12fd89d69c7f008c5e0e95de3cf2f3a374e171d13d8da7 ui-remove-husky.patch"
diff --git a/community/nomad/nomad.confd b/community/nomad/nomad.confd
deleted file mode 100644
index 3161e31c3c7..00000000000
--- a/community/nomad/nomad.confd
+++ /dev/null
@@ -1 +0,0 @@
-nomad_opts="agent -server -config=/etc/nomad.d"
diff --git a/community/nomad/nomad.initd b/community/nomad/nomad.initd
deleted file mode 100644
index 05949fd87ac..00000000000
--- a/community/nomad/nomad.initd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/openrc-run
-name="Nomad"
-description="An easy-to-use, flexible, and performant workload orchestrator"
-description_healthcheck="Check health status"
-description_reload="Reload configuration"
-
-extra_started_commands="healthcheck reload"
-
-command="/usr/sbin/${RC_SVCNAME}"
-command_args="${nomad_opts}"
-command_user="root:root"
-
-supervisor=supervise-daemon
-output_log="/var/log/${RC_SVCNAME}.log"
-error_log="/var/log/${RC_SVCNAME}.log"
-respawn_max=0
-respawn_delay=10
-healthcheck_timer=60
-
-depend() {
- need net
- after firewall
-}
-
-start_pre() {
- checkpath -f -m 0644 -o "$command_user" "$output_log" "$error_log"
-}
-
-healthcheck() {
- $command agent-info > /dev/null 2>&1
-}
-
-reload() {
- start_pre \
- && ebegin "Reloading $RC_SVCNAME configuration" \
- && $supervisor "$RC_SVCNAME" --signal HUP
- eend $?
-}
diff --git a/community/nomad/nvidia-driver.patch b/community/nomad/nvidia-driver.patch
deleted file mode 100644
index 6ce01343fe6..00000000000
--- a/community/nomad/nvidia-driver.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Disable the Nvidia GPU device plugin as this requires NVIDIA drivers.
-diff --git a/devices/gpu/nvidia/nvml/driver_default.go b/devices/gpu/nvidia/nvml/driver_default.go
-index e67efa22e..215ccfc53 100644
---- a/devices/gpu/nvidia/nvml/driver_default.go
-+++ b/devices/gpu/nvidia/nvml/driver_default.go
-@@ -1,5 +1,3 @@
--// +build !linux
--
- package nvml
-
- // Initialize nvml library by locating nvml shared object file and calling ldopen
-diff --git a/devices/gpu/nvidia/nvml/driver_linux.go b/devices/gpu/nvidia/nvml/driver_linux.go
-index bdd777561..ad68efa32 100644
---- a/devices/gpu/nvidia/nvml/driver_linux.go
-+++ b/devices/gpu/nvidia/nvml/driver_linux.go
-@@ -1,3 +1,5 @@
-+// +build !linux
-+
- package nvml
-
- import (
diff --git a/community/nomad/server.hcl b/community/nomad/server.hcl
deleted file mode 100644
index 61602fb0362..00000000000
--- a/community/nomad/server.hcl
+++ /dev/null
@@ -1,12 +0,0 @@
-data_dir = "/var/lib/nomad"
-disable_update_check = true
-enable_syslog = true
-
-server {
- enabled = true
- bootstrap_expect = 1
-}
-
-client {
- enabled = true
-}
diff --git a/community/nomad/ui-remove-husky.patch b/community/nomad/ui-remove-husky.patch
deleted file mode 100644
index 72881696fc9..00000000000
--- a/community/nomad/ui-remove-husky.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Husky is an npm package which will automatically, without confirmation,
-git hooks into the 'current' repository. When building this package,
-this repository will be aports, which is unwanted to put it mildly.
-
-diff --git a/ui/package.json b/ui/package.json
-index 0fcd03deae..6c7ae337bf 100644
---- a/ui/package.json
-+++ b/ui/package.json
-@@ -110,7 +110,6 @@
- "fuse.js": "^3.4.4",
- "glob": "^4.0.5",
- "http-proxy": "^1.1.6",
-- "husky": "^4.2.5",
- "is-ip": "^3.1.0",
- "ivy-codemirror": "IvyApp/ivy-codemirror#c3b7f49f8e6492878619f8055695581240cce21a",
- "lint-staged": "^10.1.3",
-diff --git a/ui/yarn.lock b/ui/yarn.lock
-index 8b5bbec3a6..7dc013d78e 100644
---- a/ui/yarn.lock
-+++ b/ui/yarn.lock
-@@ -10232,22 +10232,6 @@ human-signals@^1.1.1:
- resolved "https://registry.yarnpkg.com/human-signals/-/human-signals-1.1.1.tgz#c5b1cd14f50aeae09ab6c59fe63ba3395fe4dfa3"
- integrity sha512-SEQu7vl8KjNL2eoGBLF3+wAjpsNfA9XMlXAYj/3EdaNfAlxKthD1xjEQfGOUhllCGGJVNY34bRr6lPINhNjyZw==
-
--husky@^4.2.5:
-- version "4.3.8"
-- resolved "https://registry.yarnpkg.com/husky/-/husky-4.3.8.tgz#31144060be963fd6850e5cc8f019a1dfe194296d"
-- integrity sha512-LCqqsB0PzJQ/AlCgfrfzRe3e3+NvmefAdKQhRYpxS4u6clblBoDdzzvHi8fmxKRzvMxPY/1WZWzomPZww0Anow==
-- dependencies:
-- chalk "^4.0.0"
-- ci-info "^2.0.0"
-- compare-versions "^3.6.0"
-- cosmiconfig "^7.0.0"
-- find-versions "^4.0.0"
-- opencollective-postinstall "^2.0.2"
-- pkg-dir "^5.0.0"
-- please-upgrade-node "^3.2.0"
-- slash "^3.0.0"
-- which-pm-runs "^1.0.0"
--
- iconv-lite@0.4.24, iconv-lite@^0.4.24:
- version "0.4.24"
- resolved "https://registry.yarnpkg.com/iconv-lite/-/iconv-lite-0.4.24.tgz#2022b4b25fbddc21d2f524974a474aafe733908b"