aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-breathe
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-breathe')
-rw-r--r--community/py3-breathe/APKBUILD31
-rw-r--r--community/py3-breathe/test_renderer.patch33
2 files changed, 55 insertions, 9 deletions
diff --git a/community/py3-breathe/APKBUILD b/community/py3-breathe/APKBUILD
index 42fe926e3a5..a368581c7bf 100644
--- a/community/py3-breathe/APKBUILD
+++ b/community/py3-breathe/APKBUILD
@@ -2,28 +2,41 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-breathe
_pkgname=breathe
-pkgver=4.30.0
-pkgrel=0
+pkgver=4.35.0
+pkgrel=3
pkgdesc="ReStructuredText and Sphinx bridge to Doxygen"
-url="http://breathe.readthedocs.org/"
+url="https://breathe.readthedocs.org/"
arch="noarch"
license="BSD-3-Clause-Clear"
depends="python3 py3-sphinx doxygen"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/michaeljones/breathe/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/breathe-doc/breathe/archive/v$pkgver.tar.gz
+ test_renderer.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- make dev-test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="fa09ee687a8e67fa480865a0d33affd9aa0ab48b0cb5b685731ec393045d8c9e1ae0622a1315f805449d712e99e6982ed229bb79314c69f69da0c705d075f7f9 py3-breathe-4.30.0.tar.gz"
+sha512sums="
+76e36fceb89c21e2c62471a37b856f8e7077f946ca8ebffdd068297d7d447ba4f42f8f9d91e231f7a181d7dba2cb8650479f35f8bef342184e5ccbd3dd951f91 py3-breathe-4.35.0.tar.gz
+daf9aec441cd3708978b6cc292ec46cde28b4df441ae5b8c9514200f647bbb60010e50125665a2723e467a48123ac991d36ddaf07d59b34fcb680a3d820cded7 test_renderer.patch
+"
diff --git a/community/py3-breathe/test_renderer.patch b/community/py3-breathe/test_renderer.patch
new file mode 100644
index 00000000000..5bb06344d6b
--- /dev/null
+++ b/community/py3-breathe/test_renderer.patch
@@ -0,0 +1,33 @@
+From 2dc8044780d140d942984f47960d0712cdd3b8ba Mon Sep 17 00:00:00 2001
+From: Gareth Rees <grees@undo.io>
+Date: Sun, 31 Mar 2024 17:17:58 +0100
+Subject: [PATCH] Update `test_renderer` so that tests pass with Sphinx 7.2.
+
+Sphinx was updated in in pull request sphinx-doc/sphinx#11526 (July
+2023) so that importing `sphinx.testing.path` no longer causes Sphinx
+application paths to belong to the class `sphinx.testing.path.path`,
+which has a `makedirs` method.
+
+Instead, Sphinx application paths are now ordinary `Path` objects
+which lack this method, so we use `os.makedirs` instead. This is
+backwards compatible as `sphinx.testing.path.path` objects are
+pathlike and so accepted by `os.makedirs`.
+
+Fixes issue #975.
+---
+ tests/test_renderer.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_renderer.py b/tests/test_renderer.py
+index a858c65d..0fd044a5 100644
+--- a/tests/test_renderer.py
++++ b/tests/test_renderer.py
+@@ -35,7 +35,7 @@ def app(test_params, app_params, make_app, shared_result):
+ """
+ args, kwargs = app_params
+ assert "srcdir" in kwargs
+- kwargs["srcdir"].makedirs(exist_ok=True)
++ os.makedirs(kwargs["srcdir"], exist_ok=True)
+ (kwargs["srcdir"] / "conf.py").write_text("")
+ app_ = make_app(*args, **kwargs)
+ yield app_