aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pep440/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pep440/APKBUILD')
-rw-r--r--community/py3-pep440/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/community/py3-pep440/APKBUILD b/community/py3-pep440/APKBUILD
index 555b6b7f01a..1b07966f05c 100644
--- a/community/py3-pep440/APKBUILD
+++ b/community/py3-pep440/APKBUILD
@@ -8,14 +8,16 @@ url="https://github.com/Carreau/pep440"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-build py3-installer py3-flit-core"
+makedepends="py3-gpep517 py3-flit-core"
checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/Carreau/pep440/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/pep440-$pkgver"
options="!check" # no checks
build() {
- python3 -m build --wheel --no-isolation --skip-dependency-check
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 1
}
package() {