aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-python-jwt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-python-jwt/APKBUILD')
-rw-r--r--community/py3-python-jwt/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-python-jwt/APKBUILD b/community/py3-python-jwt/APKBUILD
new file mode 100644
index 00000000000..46f5975ef42
--- /dev/null
+++ b/community/py3-python-jwt/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rejah Rehim <rejah@beaglesecurity.com>
+# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
+pkgname=py3-python-jwt
+_pkgname=python_jwt
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Module for generating and verifying JSON Web Tokens"
+options="!check" # no test suite
+url="https://github.com/davedoesdev/python-jwt"
+arch="noarch"
+license="MIT"
+depends="python3 py3-jwcrypto"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ install -Dm644 LICENCE "$pkgdir"/usr/share/licenses/$pkgname/LICENCE
+ install -Dm644 README.md "$pkgdir"/usr/share/licenses/$pkgname/README.md
+}
+
+sha512sums="
+fb6f39723c60659e09915ee36b2742974d73353e9026c1ac536d3256bd7bff55b596b68af51a882a7e8c52b9caf960c3888a417cc0361d0edd313f9167fabb55 python_jwt-4.1.0.tar.gz
+"