aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pyzmq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pyzmq/APKBUILD')
-rw-r--r--community/py3-pyzmq/APKBUILD34
1 files changed, 26 insertions, 8 deletions
diff --git a/community/py3-pyzmq/APKBUILD b/community/py3-pyzmq/APKBUILD
index 8c3099e3d84..5f81dc99fc2 100644
--- a/community/py3-pyzmq/APKBUILD
+++ b/community/py3-pyzmq/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-pyzmq
_pkgname=pyzmq
-pkgver=19.0.2
+pkgver=25.1.2
pkgrel=1
pkgdesc="Python bindings for ZeroMQ"
-url="https://pypi.python.org/pypi/pyzmq"
-arch="all !mips !mips64 !s390x" # https://github.com/zeromq/pyzmq/issues/1274
+url="https://pypi.org/project/pyzmq"
+arch="all"
license="LGPL-3.0-or-later AND BSD-3-Clause"
-depends="python3"
+depends="python3 py3-tornado"
makedepends="python3-dev py3-setuptools zeromq-dev"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -24,17 +25,34 @@ build() {
check() {
python3 setup.py build_ext --inplace
# TestAsyncioAuthentication hangs
- py.test-3 -v \
+ # TestPubLog random failures on ppc64le/s390x/aarch64
+ # https://github.com/zeromq/pyzmq/issues/1853
+ pytest -v \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_blank_root_topic \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_custom_debug_formatter \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_custom_global_formatter \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_init_iface \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_init_socket \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_root_topic \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_set_info_formatter_via_property \
+ --deselect zmq/tests/test_log.py::TestPubLog::test_unicode_message \
--deselect zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_blacklist \
--deselect zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_curve \
--deselect zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_plain \
--deselect zmq/tests/test_context.py::TestContext::test_mockable \
--deselect zmq/tests/test_cython.py::test_cython[3] \
- --deselect zmq/tests/test_cython.py::test_cython[2]
+ --deselect zmq/tests/test_cython.py::test_cython[2] \
+ --deselect zmq/tests/test_zmqstream.py::test_callable_check \
+ --deselect zmq/tests/test_zmqstream.py::test_on_recv_basic \
+ --deselect zmq/tests/test_zmqstream.py::test_on_recv_wake \
+ --deselect zmq/tests/test_zmqstream.py::test_on_recv_async \
+ --deselect zmq/tests/test_zmqstream.py::test_on_recv_async_error
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="aca37b54e07fe6c3c16be56aa5bd856bbf0f4d7bebd11bd9fdecc6e74b7f996572f1dc52e32ae94562c5a63391975a1caeb04d3c0af9f82f780dbee37aae1a9f pyzmq-19.0.2.tar.gz"
+sha512sums="
+e2f9fec2cf65ee2cb4416a4d3562617d1fa202e2a446d51fa31e85c6b842e385fc32e3682a68119ff678a9ebd22c3e41fff37ab01d8efa9d4cb1f680a0f87e67 pyzmq-25.1.2.tar.gz
+"