aboutsummaryrefslogtreecommitdiffstats
path: root/main/libedit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libedit/APKBUILD')
-rw-r--r--main/libedit/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/main/libedit/APKBUILD b/main/libedit/APKBUILD
index 9795a069a82..1c48d7d0231 100644
--- a/main/libedit/APKBUILD
+++ b/main/libedit/APKBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libedit
-pkgver=20210714.3.1
+pkgver=20230828.3.1
_ver=${pkgver/./-}
-pkgrel=0
+pkgrel=4
pkgdesc="BSD line editing library"
url="https://www.thrysoee.dk/editline"
arch="all"
license="BSD-3-Clause"
-depends_dev="ncurses-dev"
+depends_dev="bsd-compat-headers ncurses-dev"
makedepends_host="$depends_dev"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="https://www.thrysoee.dk/editline/libedit-$_ver.tar.gz"
@@ -35,9 +35,16 @@ package() {
# Prevent conflict with editline-doc and readline-doc
mv "$pkgdir"/usr/share/man/man3/editline.3 \
"$pkgdir"/usr/share/man/man3/libedit.3
+
+ # update symlinks
+ find "$pkgdir"/usr/share/man/man3/ -type l | while IFS= read -r path; do
+ [ "$(readlink "$path")" != 'editline.3.gz' ] && continue
+ echo ln -s -f -T -- 'libedit.3.gz' "$path"
+ done
+
rm "$pkgdir"/usr/share/man/man3/history.3*
}
sha512sums="
-a343844274bedc89f9a64a20fd5e2dae07cdc29e74c2f39d5b71468bd6ec5534d96547572962b09e54ddc2b23b47ebe2c53adba977ab14779155b21b4a73b33c libedit-20210714-3.1.tar.gz
+c7232376ef1bc128ed79f950a5f1f207f874011218682d7e6186f76443927df5483b46c4daa8cf02e327079259aee1a56e2b791aa682491eb802d90ff8940cca libedit-20230828-3.1.tar.gz
"