aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-tox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py3-tox/APKBUILD')
-rw-r--r--main/py3-tox/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/main/py3-tox/APKBUILD b/main/py3-tox/APKBUILD
deleted file mode 100644
index 7582dcfb025..00000000000
--- a/main/py3-tox/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=py3-tox
-_pkgname=${pkgname#py3-*}
-pkgver=3.14.6
-pkgrel=0
-pkgdesc="virtualenv management and test command line tool"
-options="!check" # Requires unpackaged py3-pytest extensions
-url="https://tox.readthedocs.org/"
-arch="noarch"
-license="MIT"
-makedepends="py3-setuptools"
-depends="
- py3-packaging
- py3-pluggy
- py3-py
- py3-six
- py3-virtualenv
- py3-toml
- py3-filelock
- "
-checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-replaces="py-tox" # Backwards compatibility
-provides="py-tox=$pkgver-r$pkgrel" # Backwards compatibility
-
-build() {
- python3 setup.py build
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-check() {
- python3 setup.py test
-}
-
-sha512sums="54fd836c7667aa4f7be80716d1f1f2aea3ef3f73a5e2d3999303f3bdb7463c9751e77d9cc338064ec11ab28e01ea59af5cdbe2c57abdd741b9d3e3f419ace473 tox-3.14.6.tar.gz"