aboutsummaryrefslogtreecommitdiffstats
path: root/main/xorgproto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xorgproto/APKBUILD')
-rw-r--r--main/xorgproto/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/main/xorgproto/APKBUILD b/main/xorgproto/APKBUILD
index 017814f2d19..774a52188d3 100644
--- a/main/xorgproto/APKBUILD
+++ b/main/xorgproto/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: prspkt <prspkt@protonmail.com>
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=xorgproto
-pkgver=2019.2
-pkgrel=2
+pkgver=2024.1
+pkgrel=0
pkgdesc="Combined X.Org X11 protocol headers"
url="https://www.x.org"
arch="noarch"
@@ -42,25 +42,19 @@ provides="bigreqsproto=$pkgver-r$pkgrel
xineramaproto=$pkgver-r$pkgrel
xproto=$pkgver-r$pkgrel
"
-source="https://xorg.freedesktop.org/archive/individual/proto/xorgproto-$pkgver.tar.bz2"
+source="https://xorg.freedesktop.org/archive/individual/proto/xorgproto-$pkgver.tar.gz"
+options="!check" # no tests
build() {
- cd "$builddir"
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
--datadir=/usr/lib \
-Dlegacy=true \
. output
- ninja -C output
+ meson compile -C output
}
package() {
- cd "$builddir"
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
# cleanup
rm -f "$pkgdir"/usr/include/X11/extensions/apple*
@@ -71,4 +65,6 @@ package() {
rm -f "$pkgdir"/usr/include/X11/extensions/XKBgeom.h # libx11-dev >= 1.6.9-r0
}
-sha512sums="cbfdf6bb3d58d4d4e7788c9ed779402352715e9899f65594fbc527b3178f1dc5e03cebc8ba5a863b3c196a1a0f2026c2d0438207ca19f81f3c8b7da0c0667904 xorgproto-2019.2.tar.bz2"
+sha512sums="
+c2d67a98c5ba9b2f4d0b844c96dab342c497710753a8878b75dbf12ecd64b105c9ee3c5fd11eb91e45960420cf8dd7d02547072a32d5c53e58e009394fe33666 xorgproto-2024.1.tar.gz
+"