aboutsummaryrefslogtreecommitdiffstats
path: root/testing/emacs-consult/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/emacs-consult/APKBUILD')
-rw-r--r--testing/emacs-consult/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/emacs-consult/APKBUILD b/testing/emacs-consult/APKBUILD
new file mode 100644
index 00000000000..a019bf66f0d
--- /dev/null
+++ b/testing/emacs-consult/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=emacs-consult
+pkgver=1.4_git20240405
+_gitrev=ea7043381b93f0a5236f8ee3f21f151380a0b0f5
+pkgrel=0
+_pkgreal=consult
+pkgdesc="Useful commands based on Emacs completing-read"
+url="https://github.com/minad/consult"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="
+ cmd:emacs
+ emacs-compat
+ "
+makedepends="emacs-nox"
+source="https://github.com/minad/consult/archive/$_gitrev/emacs-consult-$_gitrev.tar.gz"
+builddir="$srcdir/$_pkgreal-$_gitrev"
+options="!check" # no tests provided
+
+build() {
+ emacs -batch -q -no-site-file -L . \
+ -eval '(setq byte-compile-error-on-warn t)' \
+ -f batch-byte-compile \
+ ./*.el
+}
+
+package() {
+ install -Dvm644 ./*.el ./*.elc \
+ -t "$pkgdir"/usr/share/emacs/site-lisp/$_pkgreal/
+
+ cd "$pkgdir"/usr/share/emacs/site-lisp/$_pkgreal
+ emacs -batch -q -no-site-file \
+ -eval "(loaddefs-generate \".\" \"$_pkgreal-loaddefs.el\")"
+}
+
+sha512sums="
+48ce64d8316f4419b6de420323f3d01df4ae7623778dc681f3ff9465d8e8544e8c47d34c3fe826a9227b03305f1d1e6d1ac021fa3710f3dc446eff83a772ccb0 emacs-consult-ea7043381b93f0a5236f8ee3f21f151380a0b0f5.tar.gz
+"