aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lolcat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/lolcat/APKBUILD')
-rw-r--r--testing/lolcat/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/lolcat/APKBUILD b/testing/lolcat/APKBUILD
index 6c7edd8f634..69618c03f53 100644
--- a/testing/lolcat/APKBUILD
+++ b/testing/lolcat/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Daniel Isaksen <d@duniel.no>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=lolcat
-pkgver=1.0
+pkgver=1.4
pkgrel=0
pkgdesc="High-performance implementation of lolcat"
url="https://github.com/jaseg/lolcat/"
arch="all"
license="WTFPL"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/${pkgname}/archive/v$pkgver.tar.gz
- fix-url-and-version.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/lolcat/archive/v$pkgver.tar.gz
+ makefile.patch
+ "
options="!check" # No upstream testsuite
build() {
@@ -20,5 +21,7 @@ package() {
make DESTDIR="$pkgdir/usr/bin" install
}
-sha512sums="5f668706c2415273140047040a9e6d02d80a1572a834503480688f46466e2750f3cf5372f364039921f6461f2dbec7fa2dbe8a5600abdf3390c2caf56d1595bf lolcat-1.0.tar.gz
-14cdd61496bc0a0fbec39a8dcfb2d16d9424abfb1c6348750cb263fbb6a416bf89c6f05e549e1205fe64128c65946dcdde2a889c162336795e838b539c9b1470 fix-url-and-version.patch"
+sha512sums="
+8f73121ef372383f5ff1d444f69a6255f5ff65abfbb4f103197480f957dcc440375c7c01be5c33247ce920ff39e34519702f7550b9b8ada2f18190d0ae948024 lolcat-1.4.tar.gz
+cddac8348b17f180daa8f4c53788dc86ab348f2d5c4c98e91b7b50010e6638750e6f1c2931d115090e8075055bef2c3d4e12218fc64b4a346bfdf543c058b262 makefile.patch
+"