aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-geoip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-geoip/APKBUILD')
-rw-r--r--testing/py3-geoip/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-geoip/APKBUILD b/testing/py3-geoip/APKBUILD
new file mode 100644
index 00000000000..18e136b703f
--- /dev/null
+++ b/testing/py3-geoip/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Weilu Jia <optix2000@gmail.com>
+# Maintainer: Weilu Jia <optix2000@gmail.com>
+pkgname=py3-geoip
+pkgver=1.3.2
+pkgrel=3
+pkgdesc="MaxMind GeoIP Legacy Database - Python API"
+url="https://github.com/maxmind/geoip-api-python"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="python3 geoip"
+makedepends="py3-setuptools python3-dev geoip-dev"
+checkdepends="py3-nose"
+options="!check" # Until there's an easy way to download legacy GeoIP DBs
+source="https://pypi.python.org/packages/source/G/GeoIP/GeoIP-$pkgver.tar.gz"
+builddir="$srcdir/GeoIP-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+313af794d839e83408b40573566fb55483c1ddd663a7919b54751bc9da85cf855f9eb17d8fdb641702740da5c5d79d79d3d7f15b82fa88092f780d0c667c4e7a GeoIP-1.3.2.tar.gz
+"