aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoni Aloy Torrens <aaloytorrens@gmail.com>2021-02-12 02:33:31 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-21 07:10:44 +0000
commit6a065681aefe3f16de2bc34018530e4f821b3d08 (patch)
tree023d294aa0182a3ca3e95651112aeae86442a100
parent50940e9e69f837507d45e3ebc473182d83abd7d1 (diff)
testing/lxqt-globalkeys: new aport
-rw-r--r--testing/lxqt-globalkeys/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/lxqt-globalkeys/APKBUILD b/testing/lxqt-globalkeys/APKBUILD
new file mode 100644
index 00000000000..ada57521e7e
--- /dev/null
+++ b/testing/lxqt-globalkeys/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-globalkeys
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Daemon used to register global keyboard shortcuts"
+url="https://github.com/lxqt/lxqt-globalkeys"
+arch="all !armhf" # armhf blocked by liblxqt and kwindowsystem
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake lxqt-build-tools liblxqt-dev
+ qt5-qttools-dev kwindowsystem-dev
+ "
+subpackages="$pkgname-dev"
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-globalkeys/releases/download/$pkgver/lxqt-globalkeys-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="a6b2de35e3deb4852e9a8462871ba0fd40c9168653b210e361ff16b7dc5c74f9c98c6427cc595578eb9bb2a34c9be702c0af65fdfb92053b1f3813070629e55b lxqt-globalkeys-0.16.0.tar.xz"