aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClayton Craft <clayton@craftyguy.net>2024-03-11 10:24:51 -0700
committerBart Ribbers <bribbers@disroot.org>2024-03-12 09:43:54 +0000
commit00f8470785b4aaf7c52f915c650fe8eed2c82687 (patch)
treecd7a711b918f2f2e0856149d40ad3244335d6b8e
parent2d3f6ad49c3b72e157b824e8f0127b88dbccd698 (diff)
community/kplotting5: new aport
This restores kplotting5 for kstars, which still requires v5.x. Partially reverts 4e7fa26ea26a81c59ae26d3327bbe13838f19208
-rw-r--r--community/kplotting5/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/kplotting5/APKBUILD b/community/kplotting5/APKBUILD
new file mode 100644
index 00000000000..b35fd2a242b
--- /dev/null
+++ b/community/kplotting5/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks-old
+pkgname=kplotting5
+pkgver=5.115.0
+pkgrel=0
+pkgdesc="Lightweight plotting framework"
+arch="all !armhf" # armhf blocked by extra-cmake-modules
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt5-qttools-dev
+ samurai
+ "
+checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/frameworks/kplotting.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="$srcdir/kplotting-$pkgver"
+
+replaces="kplotting<=5.110.0-r0"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ cmake --build build
+}
+
+check() {
+ xvfb-run ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+cbe3ec13f9282024ddecedd4de03b877fedecdcf71d49a023cd7aded999017f6c373ebc4b4edbb80bbf4f4d6df891b03542241b706a61c97419358e91916cf1c kplotting-5.115.0.tar.xz
+"