aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIztok Fister Jr <iztok@iztok-jr-fister.eu>2022-06-24 17:56:14 +0000
committeralice <alice@ayaya.dev>2022-06-25 03:53:13 +0000
commit07ed5f94bf753cd6f33d8ad74ed2510cc85498b9 (patch)
tree9ee903db48ac31e96259028d5d455d5036379911
parent39d2abcf66a15cddb8c96e9febc5946fcae52460 (diff)
testing/py3-habanero: new aport
-rw-r--r--testing/py3-habanero/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-habanero/APKBUILD b/testing/py3-habanero/APKBUILD
new file mode 100644
index 00000000000..28c0c498f26
--- /dev/null
+++ b/testing/py3-habanero/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-habanero
+_pkgorig=habanero
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A low level client for working with Crossref’s search API"
+url="https://github.com/sckott/habanero"
+arch="noarch"
+license="MIT"
+options="!check" # disable due to the network tests
+depends="python3 py3-requests py3-tqdm"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/h/habanero/habanero-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgorig-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+a2f6448fb7829ae03b568080e93d595e3d5f4e5d129720b5740ff96f78f7fc294412ad5792ac39811e7a653374f9e8239ec9e5b9b70798636023884f31c7cdbc py3-habanero-1.2.2.tar.gz
+"