aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2024-04-16 17:51:37 +0200
committeromni <omni+alpine@hack.org>2024-04-16 17:45:25 +0000
commit09d464103af8ecaee31043e23886eafe89bf6804 (patch)
treefa96abfa3b8d193027d9abe0e28538a98d3179fb
parentf75ea1e5ee9ae5eaea3addf5474af54f6e1f9166 (diff)
community/py3-term-image: new aport
https://github.com/AnonymouX47/term-image Display images in the terminal with Python community/
-rw-r--r--community/py3-term-image/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/py3-term-image/APKBUILD b/community/py3-term-image/APKBUILD
new file mode 100644
index 00000000000..13d31b1303c
--- /dev/null
+++ b/community/py3-term-image/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=py3-term-image
+_pyname=term-image
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="Display images in the terminal with Python"
+url="https://github.com/AnonymouX47/term-image"
+arch="noarch"
+license="MIT"
+depends="py3-pillow py3-requests"
+checkdepends="py3-pytest py3-urwid"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
+source="$_pyname-$pkgver.tar.gz::https://github.com/AnonymouX47/term-image/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # test_url uses network
+ .testenv/bin/python3 -m pytest --deselect tests/test_image/test_url.py
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+be7c2393ee0d139f82bbee5df7ea7c130fd6770b37d667365e3370a6bf28ec823abf37e1467e1e791a30baa904256681008b9301deee4a2e364a33a1ea436b2d term-image-0.7.1.tar.gz
+"