aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2024-03-13 12:04:47 +0100
committerptrcnull <git@ptrcnull.me>2024-03-13 12:04:47 +0100
commit13cfc91d488a24fe1b13fb2aa892d7bdeb491243 (patch)
treed7fd4460f11f56de0a09d5b4a2dec91285f66375
parent11522c1237eecea0fba141e82d4de4db4db23535 (diff)
testing/fscryptctl: new aport
-rw-r--r--testing/fscryptctl/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/fscryptctl/APKBUILD b/testing/fscryptctl/APKBUILD
new file mode 100644
index 00000000000..ee6862d0f0f
--- /dev/null
+++ b/testing/fscryptctl/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Luca Weiss <luca@z3ntu.xyz>
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=fscryptctl
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Small C tool for Linux filesystem encryption"
+url="https://github.com/google/fscryptctl"
+arch="all"
+license="Apache-2.0"
+makedepends="linux-headers"
+source="https://github.com/google/fscryptctl/archive/v$pkgver/fscryptctl-$pkgver.tar.gz"
+options="!check" # tests require root
+
+# Skip building docs because pandoc is only available for x86_64 and aarch64
+
+build() {
+ make fscryptctl
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install-bin
+}
+
+sha512sums="
+3ee37d3b10a145b2c50fa56644461313437d97f9ca1a840f6e897f527c5bf6c15af1172a1994b3ff0038f469a74edfa40f7383c08f24b195a78f3f5d35dd895b fscryptctl-1.1.0.tar.gz
+"