aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach DeCook <zachdecook@librem.one>2024-02-22 19:19:59 -0500
committeromni <omni+alpine@hack.org>2024-02-24 15:12:32 +0000
commit244390ffb23fea7936a1b0344484ff6f8f797a92 (patch)
treecdeb2485127254227aab2048f5d3a26a64be79f9
parent250508778b1e9f192f8275c5eb21b49287cf14a5 (diff)
community/tomlplusplus: move from testing and add LICENSE
-rw-r--r--community/tomlplusplus/APKBUILD (renamed from testing/tomlplusplus/APKBUILD)5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/tomlplusplus/APKBUILD b/community/tomlplusplus/APKBUILD
index 256d14a74c4..14a5ebe87bd 100644
--- a/testing/tomlplusplus/APKBUILD
+++ b/community/tomlplusplus/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Zach DeCook <zachdecook@librem.one>
pkgname=tomlplusplus
pkgver=3.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Header-only TOML config file parser and serializer for C++17."
url="https://marzer.github.io/tomlplusplus/"
arch="all"
license="MIT"
source="https://github.com/marzer/tomlplusplus/archive/v3.4.0/tomlplusplus-v3.4.0.tar.gz"
makedepends="cmake meson nlohmann-json catch2-3"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-doc"
build() {
abuild-meson . output
@@ -22,6 +22,7 @@ check() {
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}