aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-03-27 08:03:31 +0000
committeromni <omni+alpine@hack.org>2024-04-02 02:35:24 +0000
commit26674b520a91a188e7a0eab62d0a40efea6ee6f3 (patch)
tree0c35e35d2f5492519a64d37dc8ee2744acccefbc
parent8b0d25e95c73cb428f7c51b379193f050538e161 (diff)
testing/emacs-pyim-basedict: new aport
https://github.com/tumashu/pyim-basedict Default Pinyin dict for Emacs-pyim
-rw-r--r--testing/emacs-pyim-basedict/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/emacs-pyim-basedict/APKBUILD b/testing/emacs-pyim-basedict/APKBUILD
new file mode 100644
index 00000000000..9a58b3532c6
--- /dev/null
+++ b/testing/emacs-pyim-basedict/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=emacs-pyim-basedict
+pkgver=0.5.3
+pkgrel=0
+_pkgreal=pyim-basedict
+pkgdesc="Default Pinyin dict for Emacs-pyim"
+url="https://github.com/tumashu/pyim-basedict"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="cmd:emacs"
+makedepends="emacs-nox emacs-pyim"
+source="https://github.com/tumashu/pyim-basedict/archive/v$pkgver/emacs-pyim-basedict-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+options="!check" # no tests provided
+
+build() {
+ emacs -batch -q -no-site-file -L . \
+ -f batch-byte-compile \
+ ./*.el
+}
+
+package() {
+ install -Dvm644 ./*.el ./*.elc ./*.pyim \
+ -t "$pkgdir"/usr/share/emacs/site-lisp/pyim/
+
+ cd "$pkgdir"/usr/share/emacs/site-lisp/pyim
+ emacs -batch -q -no-site-file \
+ -eval "(loaddefs-generate \".\" \"$_pkgreal-loaddefs.el\")"
+}
+
+sha512sums="
+453a4caab29195baac23160ee95116af7033852e8cd79fd9824e5efe94c6bc480709457817c388b68bdf1ac002e01297e8395abd517a0a17d121cc5705d392fe emacs-pyim-basedict-0.5.3.tar.gz
+"