aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-03-31 16:12:59 +0000
committeromni <omni+alpine@hack.org>2024-04-09 14:43:19 +0000
commit2c7853eb82f2c217d5d5221db2a3a690e1282db2 (patch)
tree10f95beecb4f29e0f86188cdb98d44ad693e52fc
parentd50d60250e3da959f3739a4365d2d015c67829e7 (diff)
testing/emacs-async-await: new aport
https://github.com/chuntaro/emacs-async-await Simple implementation of Async/Await Dependency of emacs-lab
-rw-r--r--testing/emacs-async-await/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/emacs-async-await/APKBUILD b/testing/emacs-async-await/APKBUILD
new file mode 100644
index 00000000000..032a0a4008e
--- /dev/null
+++ b/testing/emacs-async-await/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=emacs-async-await
+pkgver=1.1_git20220826
+_gitrev=5d5b6ea07c09e3ec42f95b13fc837608658324e1
+pkgrel=0
+_pkgreal=async-await
+pkgdesc="Simple implementation of Async/Await"
+url="https://github.com/chuntaro/emacs-async-await"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="
+ cmd:emacs
+ emacs-iter2
+ emacs-promise
+ "
+makedepends="emacs-nox"
+source="https://github.com/chuntaro/emacs-async-await/archive/$_gitrev/emacs-async-await-$_gitrev.tar.gz"
+builddir="$srcdir/$pkgname-$_gitrev"
+options="!check" # no tests provided
+
+build() {
+ emacs -batch -q -no-site-file -L . \
+ -eval '(setq byte-compile-error-on-warn t)' \
+ -f batch-byte-compile \
+ ./*.el
+}
+
+package() {
+ install -Dvm644 ./*.el ./*.elc \
+ -t "$pkgdir"/usr/share/emacs/site-lisp/
+
+ cd "$pkgdir"/usr/share/emacs/site-lisp
+ emacs -batch -q -no-site-file \
+ -eval "(loaddefs-generate \".\" \"$_pkgreal-loaddefs.el\")"
+}
+
+sha512sums="
+0967347fed289fb71f2acc7b0118b77cc5e91b3d5acd6d7b9d604832420f88e70e68210bdee4d858aa0ca437b080a36a599939a979069b8d1a21f83cf2469236 emacs-async-await-5d5b6ea07c09e3ec42f95b13fc837608658324e1.tar.gz
+"