aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-02-14 15:45:52 +0000
committeromni <omni+alpine@hack.org>2024-02-24 12:45:12 +0000
commit32b20eb789f54f663d0634d9725f32f8e44bfcce (patch)
treee219c79f77d209d34ebfa1fc11a3d69c67cbd612
parentdd4f3c299ff4cf2f76f59094e09c6c6abc722711 (diff)
testing/perl-css-object: new aport
https://metacpan.org/release/CSS-Object/ Object-oriented CSS parser and manipulation interface
-rw-r--r--testing/perl-css-object/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-css-object/APKBUILD b/testing/perl-css-object/APKBUILD
new file mode 100644
index 00000000000..a2d555614b5
--- /dev/null
+++ b/testing/perl-css-object/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 4
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=perl-css-object
+pkgver=0.1.6
+pkgrel=0
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=CSS-Object
+pkgdesc="Object-oriented CSS parser and manipulation interface"
+url="https://metacpan.org/release/CSS-Object/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-devel-confess perl-module-generic perl-want"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/J/JD/JDEGUEST/CSS-Object-v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-v$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+ INSTALLDIRS=vendor \
+ NO_PACKLIST=1 \
+ NO_PERLLOCAL=1
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+4f7aeb5086d58a1466b4ac21fd931fdd2d8d11114a8e1b218ccb76c454a5df35e427ae64d1383564ce19aee8c933216d9e4b79303d8c0299eefd95014fd43e2e CSS-Object-v0.1.6.tar.gz
+"