aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2022-10-10 21:46:58 +0000
committeromni <omni+alpine@hack.org>2022-10-10 21:52:26 +0000
commit4d277d1b75dca2258eb984b0cd1ed9f1de7da050 (patch)
tree246702167dfbbebd123a530e00b93d493c09a21e
parent86e1983daf5c97f2725d649597abafe98ce488b6 (diff)
community/py3-gpep517: backport from edge
This may look like it's moved from testing but I just removed it from there for good measure, I took the currently latest py3-gpep517 from edge.
-rw-r--r--community/py3-gpep517/APKBUILD (renamed from testing/py3-gpep517/APKBUILD)16
-rw-r--r--community/py3-gpep517/gpep5176
2 files changed, 18 insertions, 4 deletions
diff --git a/testing/py3-gpep517/APKBUILD b/community/py3-gpep517/APKBUILD
index 0ea1329d6ec..9df2c693038 100644
--- a/testing/py3-gpep517/APKBUILD
+++ b/community/py3-gpep517/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=py3-gpep517
_pkgname=gpep517
-pkgver=6
+pkgver=9
pkgrel=0
pkgdesc="Minimal backend script to aid installing Python packages through PEP 517-compliant build systems"
url="https://github.com/mgorny/gpep517/"
@@ -10,16 +10,24 @@ arch="noarch"
license="MIT"
# python 3.11: remove py3-tomli
depends="py3-installer py3-tomli python3"
-source="https://github.com/mgorny/gpep517/archive/v$pkgver/gpep517-v$pkgver.tar.gz"
+source="https://github.com/mgorny/gpep517/archive/v$pkgver/gpep517-v$pkgver.tar.gz
+ gpep517
+ "
builddir="$srcdir/$_pkgname-$pkgver"
-options="!check" # skip check since intended to be a low-level bootstrap package
+
+check() {
+ python3 -m gpep517 --help
+}
package() {
local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
mkdir -p "$pkgdir/$sitedir"
cp -a gpep517 "$pkgdir/$sitedir"
+
+ install -Dm755 "$srcdir"/gpep517 -t "$pkgdir"/usr/bin
}
sha512sums="
-681108dab418d0d2d5b017f19bf8802479655f22eb6b72e9d78c6bbd2d08583751a465377c2006c507f0ea258d2d46bf9300865896af4458a763b56a86abe329 gpep517-v6.tar.gz
+94cd1ddb1de7844504906b056ec5eb9d0e80da4f6bde6b561075c754a78a97e6db6025a793592c9498fad54ebab48c5497b29268c40d6992f5ef793a698b9da1 gpep517-v9.tar.gz
+3e90bf2d94006672c66f5082812115903054b6e05a5d37aa9a0fd33f7b2c8368f13e5fbd3ea815c386d6155dcbf8babd69faa9ca27b95f35b35a4ef47974efd7 gpep517
"
diff --git a/community/py3-gpep517/gpep517 b/community/py3-gpep517/gpep517
new file mode 100644
index 00000000000..b8b10c0c09d
--- /dev/null
+++ b/community/py3-gpep517/gpep517
@@ -0,0 +1,6 @@
+#!/usr/bin/python3
+# -*- coding: utf-8 -*-
+import sys
+from gpep517.__main__ import main
+if __name__ == "__main__":
+ sys.exit(main())