aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-24 10:15:47 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-24 10:16:01 +0200
commit541b723df5cf9a165a12856802be61d5a96de634 (patch)
treeb436d0091ebc521e51cb1fa9af05d060cbd5266d
parenta4e27a60678d1c22d8210cd576c500f511a1ff42 (diff)
community/perl-mail-sendmail: fix license, cleanup
-rw-r--r--community/perl-mail-sendmail/APKBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/community/perl-mail-sendmail/APKBUILD b/community/perl-mail-sendmail/APKBUILD
index 47712961c40..056678260d7 100644
--- a/community/perl-mail-sendmail/APKBUILD
+++ b/community/perl-mail-sendmail/APKBUILD
@@ -4,15 +4,12 @@
pkgname=perl-mail-sendmail
_pkgreal=Mail-Sendmail
pkgver=0.80
-pkgrel=2
+pkgrel=3
pkgdesc="Simple platform independent mailer"
url="https://metacpan.org/release/Mail-Sendmail/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
checkdepends="python3"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz
@@ -23,19 +20,16 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
# run dummy smtp server
python3 "$srcdir"/fake-smtp.py &
local pid=$!
@@ -48,7 +42,6 @@ check() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}