aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-02-12 21:15:59 +0100
committerJakub Jirutka <jakub@jirutka.cz>2022-02-12 22:15:48 +0100
commit5d8292ea4d3ec84c97c5f04923f3741bc7cffb94 (patch)
tree01037be64bac954eefa1c5ed91a0668bfdffd5fd
parentb1b636339ba8911f984d7d315d32e5a49477079f (diff)
community/zsh-syntax-highlighting: fix .revision-hash
-rw-r--r--community/zsh-syntax-highlighting/APKBUILD11
-rw-r--r--community/zsh-syntax-highlighting/ungit.patch17
2 files changed, 25 insertions, 3 deletions
diff --git a/community/zsh-syntax-highlighting/APKBUILD b/community/zsh-syntax-highlighting/APKBUILD
index 52e1302c372..18b4f028f72 100644
--- a/community/zsh-syntax-highlighting/APKBUILD
+++ b/community/zsh-syntax-highlighting/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
pkgname=zsh-syntax-highlighting
pkgver=0.7.1
-pkgrel=0
+pkgrel=1
pkgdesc="Fish shell like syntax highlighting for Zsh"
url="https://github.com/zsh-users/zsh-syntax-highlighting"
arch="noarch"
license="BSD-3-Clause"
depends="zsh"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
+ ungit.patch
+ "
build() {
make
@@ -24,4 +26,7 @@ package() {
SHARE_DIR="$pkgdir/usr/share/zsh/plugins/$pkgname"
}
-sha512sums="e7e86b88cdac9b9ed5f973823ba8efff99dd720b9ed929f765f9f9266b9d6e147274f5957ceb630d51a660e396fc22e97f10cfbc5cdde941b907f3773bb1ea2b zsh-syntax-highlighting-0.7.1.tar.gz"
+sha512sums="
+e7e86b88cdac9b9ed5f973823ba8efff99dd720b9ed929f765f9f9266b9d6e147274f5957ceb630d51a660e396fc22e97f10cfbc5cdde941b907f3773bb1ea2b zsh-syntax-highlighting-0.7.1.tar.gz
+fbcc80362269bef7902b153470a4dbf0031c30d4bc92a2efaccf2b74b70cd26ff0202011e8ca63bce68bac3a3dbd47cc3c1015358aed8cf12332942fd186ab2d ungit.patch
+"
diff --git a/community/zsh-syntax-highlighting/ungit.patch b/community/zsh-syntax-highlighting/ungit.patch
new file mode 100644
index 00000000000..bbaa2fdabae
--- /dev/null
+++ b/community/zsh-syntax-highlighting/ungit.patch
@@ -0,0 +1,17 @@
+Don't read revision hash from the git repository.
+
+--- a/Makefile
++++ b/Makefile
+@@ -18,11 +18,7 @@
+ cp .version zsh-syntax-highlighting.zsh $(SHARE_DIR)
+ cp COPYING.md README.md changelog.md $(DOC_DIR)
+ sed -e '1s/ .*//' -e '/^\[build-status-[a-z]*\]: /d' < README.md > $(DOC_DIR)/README.md
+- if [ x"true" = x"`git rev-parse --is-inside-work-tree 2>/dev/null`" ]; then \
+- git rev-parse HEAD; \
+- else \
+- cat .revision-hash; \
+- fi > $(SHARE_DIR)/.revision-hash
++ cp .revision-hash $(SHARE_DIR)
+ :
+ # The [ -e ] check below is to because sh evaluates this with (the moral
+ # equivalent of) NONOMATCH in effect, and highlighters/*.zsh has no matches.