aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@posteo.net>2024-03-13 12:00:13 +0100
committerAndy Postnikov <apostnikov@gmail.com>2024-03-14 23:20:17 +0000
commit5da0f6e5980b551d0dd83db50020d5f802a370c1 (patch)
tree2ef0e6cf095aff67600b0f291914e34c76e98bb4
parentc2ababc1304156a02f7596a66d03253fa50cdbff (diff)
community/lib3mf: upgrade to 2.3.0
Also enable unit tests, which now can be run on the release tarball.
-rw-r--r--community/lib3mf/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/lib3mf/APKBUILD b/community/lib3mf/APKBUILD
index 4d16134f5db..efe17093c68 100644
--- a/community/lib3mf/APKBUILD
+++ b/community/lib3mf/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=lib3mf
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=0
pkgdesc="A C++ implementation of the 3D Manufacturing Format file standard"
url="https://github.com/3MFConsortium/lib3mf"
@@ -16,7 +16,6 @@ makedepends="
zlib-dev
"
source="$pkgname-$pkgver.tar.gz::https://github.com/3MFConsortium/lib3mf/archive/v$pkgver.tar.gz"
-options="!check" # Unit tests requires source code of googletest, which is git submodule but not included in the release
build() {
cmake -B build \
@@ -27,10 +26,14 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_INCLUDED_ZLIB=OFF \
-DUSE_INCLUDED_LIBZIP=OFF \
- -DLIB3MF_TESTS=FALSE
+ -DLIB3MF_TESTS=ON
cmake --build build
}
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
package() {
DESTDIR="$pkgdir" cmake --install build
# fix Cflags in lib3mf.pc
@@ -42,5 +45,5 @@ package() {
}
sha512sums="
-2a9ee92312396b8966967a7ed696c58c69a77438f94432ad071659adc8c9d12fba34a3cf3d8c8d3ad3b26c12c9a89f4d8645e6f396987dc05b04952b004a1f07 lib3mf-2.2.0.tar.gz
+5bd7ac080905880c14a97211532fe484dce8a07e8444bce0270dd81823afc2247ad1c6770bcdb16ac8723675b49016852f3de887965ee8ec5fd39cc3c8ca31e0 lib3mf-2.3.0.tar.gz
"