aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-04-21 21:56:38 +0000
committerpsykose <alice@ayaya.dev>2023-04-21 23:56:38 +0200
commit68bfe6687a4572b8485af689422e06dc8ab5b3f6 (patch)
tree53d4a8795ba2574ea8f4e360e974238c59d66d22
parent7b79432448187e53c381a60cbfe4f45ecf5a962b (diff)
community/lbreakouthd: remove some Wno flags
-rw-r--r--community/lbreakouthd/APKBUILD2
-rw-r--r--community/lbreakouthd/format-security.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/community/lbreakouthd/APKBUILD b/community/lbreakouthd/APKBUILD
index 05aae121592..db5fe885e48 100644
--- a/community/lbreakouthd/APKBUILD
+++ b/community/lbreakouthd/APKBUILD
@@ -17,6 +17,7 @@ makedepends="
subpackages="$pkgname-lang $pkgname-data::noarch"
source="https://sourceforge.net/projects/lgames/files/lbreakouthd/lbreakouthd-$pkgver.tar.gz
0001-fix-undeclared-uint.patch
+ format-security.patch
"
options="!check" # No test suite
@@ -49,4 +50,5 @@ data() {
sha512sums="
83195755921cc9f763de2e5347219a2b2be35e4ba9fa520c3ad5909519c6decc05cf1e442f64a893624ba1b6ac32941f2ca770f65b93a6bfcd1164876f1b872b lbreakouthd-1.1.2.tar.gz
4de6934a7840153354f54c5c6a9c14d22e3d5a76030cd33131c2511d97c363d73912d53d3581fd756ff42dec9c7d4e819056e5a2eee5d92064a88a9337abe5eb 0001-fix-undeclared-uint.patch
+1600c7cb2c655d775b08961e7752979367c218917f628682e598816e33233cea7c3450c6f03005186dc8f6411d256733da4ed93284d4517608db9167bd189ce5 format-security.patch
"
diff --git a/community/lbreakouthd/format-security.patch b/community/lbreakouthd/format-security.patch
new file mode 100644
index 00000000000..6295204f7d1
--- /dev/null
+++ b/community/lbreakouthd/format-security.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index dcd8fbe..351b0d0 100755
+--- a/configure
++++ b/configure
+@@ -12111,7 +12111,7 @@ fi
+
+
+
+-CFLAGS="$CFLAGS -Wno-int-conversion -Wno-format -Wno-implicit-function-declaration"
++CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $debugflags -DSRC_DIR=\\\"$datdir\\\" -DCONFIG_DIR_NAME=\\\"$configdir\\\""
+ CXXFLAGS="$CXXFLAGS -std=c++11 -Wall $debugflags -DLOCALEDIR=\\\"$localedir\\\" -DCONFIGDIR=\\\"$configdir\\\" -DDATADIR=\\\"$datdir\\\" -DHISCOREDIR=\\\"$hiscoredir\\\""
+