aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Sinatra <wpsinatra@gmail.com>2023-12-02 00:11:45 -0500
committeromni <omni+alpine@hack.org>2024-01-03 17:55:18 +0000
commit75ac9c61fca4bccf28ef97078d2065e047a502f1 (patch)
tree9ecf4219a68e9897da40b89686046bbbc1af118e
parent4b10a1eb53194496324e8a1a4708a8e4032d1f1e (diff)
community/lua-lapis-annotate: move from testing
-rw-r--r--community/lua-lapis-annotate/APKBUILD (renamed from testing/lua-lapis-annotate/APKBUILD)9
-rw-r--r--community/lua-lapis-annotate/LICENSE21
-rw-r--r--community/lua-lapis-annotate/fix_lua_ver.patch (renamed from testing/lua-lapis-annotate/fix_lua_ver.patch)0
-rw-r--r--testing/lua-lapis-console/APKBUILD63
4 files changed, 28 insertions, 65 deletions
diff --git a/testing/lua-lapis-annotate/APKBUILD b/community/lua-lapis-annotate/APKBUILD
index c05fd6fb13a..e753a39dad0 100644
--- a/testing/lua-lapis-annotate/APKBUILD
+++ b/community/lua-lapis-annotate/APKBUILD
@@ -3,17 +3,19 @@
pkgname=lua-lapis-annotate
_rockname=lapis-annotate
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="A Lapis extension that lets you annotate your model files with their schema."
url="https://github.com/leafo/lapis-annotate"
arch="noarch !ppc64le" #blocked by lua-lapis, which requires lua-etlua
license="MIT"
makedepends="luarocks"
source="$pkgname-$pkgver.tar.gz::https://github.com/leafo/$_rockname/archive/v$pkgver.tar.gz
- fix_lua_ver.patch"
+ fix_lua_ver.patch
+ LICENSE"
builddir="$srcdir/$_rockname-$pkgver"
depends="lua-lapis"
options="!check" #There are no checks
+subpackages="$pkgname-doc"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
@@ -43,6 +45,8 @@ build() {
package() {
mkdir -p "$pkgdir"
+
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
_subpackage() {
@@ -64,4 +68,5 @@ _subpackage() {
sha512sums="
59276d5a95762b414c714cd02f642cffb4eef43e4e575e9c3f5d3c9f9a5304e1afdedebffd8a4ea2f282d94cc3834cb1696b2dc7daf67e0451eab7534564a072 lua-lapis-annotate-1.2.1.tar.gz
45353ee44f363ecba441817658c2f30e053ff28901bb954b97119874f461b2716a19216fc38d168c14072d09a599f5aab4fe60543a0ae6882318f961d56761ae fix_lua_ver.patch
+8d23c78a24f99ffc27adbc75402368ea7445034c31124966fed9ccf7e0fbf31358b6ff09719a390452145c33040174b3cf8cb89e3eb54804eb7d6c2c86abff2f LICENSE
"
diff --git a/community/lua-lapis-annotate/LICENSE b/community/lua-lapis-annotate/LICENSE
new file mode 100644
index 00000000000..961efa013ef
--- /dev/null
+++ b/community/lua-lapis-annotate/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2023 Leaf Corcoran
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/testing/lua-lapis-annotate/fix_lua_ver.patch b/community/lua-lapis-annotate/fix_lua_ver.patch
index ec5638b616e..ec5638b616e 100644
--- a/testing/lua-lapis-annotate/fix_lua_ver.patch
+++ b/community/lua-lapis-annotate/fix_lua_ver.patch
diff --git a/testing/lua-lapis-console/APKBUILD b/testing/lua-lapis-console/APKBUILD
deleted file mode 100644
index 89476125de7..00000000000
--- a/testing/lua-lapis-console/APKBUILD
+++ /dev/null
@@ -1,63 +0,0 @@
-# Contributor: Will Sinatra <wpsinatra@gmail.com>
-# Maintainer: Will Sinatra <wpsinatra@gmail.com>
-pkgname=lua-lapis-console
-_rockname=lapis-console
-pkgver=1.2.0
-pkgrel=0
-pkgdesc="An interactive console for the Lapis web framework."
-url="https://github.com/leafo/lapis-console"
-arch="noarch !ppc64le" #blocked by lua-lapis, which requires lua-etlua
-license="MIT"
-makedepends="luarocks"
-source="$pkgname-$pkgver.tar.gz::https://github.com/leafo/$_rockname/archive/v$pkgver.tar.gz
- fix_lua_ver.patch"
-builddir="$srcdir/$_rockname-$pkgver"
-depends="lua-lapis"
-options="!check" #There are no checks
-
-_luaversions="5.1 5.2 5.3 5.4"
-for _v in $_luaversions; do
- makedepends="$makedepends lua$_v-dev luarocks$_v"
- subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
- depends="$depends lua$_v lua$_v-lapis"
-done
-
-build() {
- local lver; for lver in $_luaversions; do
- msg "Building for Lua $lver..."
-
- luarocks-$lver \
- LUA_INCDIR="$(pkg-config --variable=includedir lua$lver)" \
- LUA_LIBDIR="$(pkg-config --variable=libdir lua$lver)" \
- make --tree="./build" \
- --deps-mode=none \
- "$_rockname-dev-1.rockspec"
-
- rm "./build/lib/luarocks/rocks-$lver/manifest"
- done
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_subpackage() {
- local lver="${subpkgname:3:3}"
- pkgdesc="$pkgdesc (for Lua $lver)"
- depends="lua$lver lua$lver-lapis"
- install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
- local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$_rockname/$pkgver-1"
-
- local path; for path in "lib/luarocks/rocks-$lver" "share/lua/$lver"; do
- mkdir -p "$subpkgdir/usr/${path%/*}"
- mv "$builddir/build/$path" "$subpkgdir/usr/$path/"
- done
-
- mkdir -p "$rockdir"
- echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
-}
-
-sha512sums="
-90124cb0b72b6588e183e9637d43b054542b49b8163a688b21735205a0161a968df1698fa4d95630b0aa8feccdc7f31e46e50437349c223a02e471e76ff63da8 lua-lapis-console-1.2.0.tar.gz
-b925424d2b8d88c034a724e40e398e73951168e6bed1ed498f48bde5cb5030e156d74f0ab4694cc1eaf5b36f38972b0f624322483cbf60cbb2ab81dcf68f2624 fix_lua_ver.patch
-"