aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2024-04-30 15:42:29 +0200
committerBart Ribbers <bribbers@disroot.org>2024-04-30 22:02:41 +0000
commit7e44153c6a36977ec430c8a60a22a4f03a25985a (patch)
treef9c0fe7bd319cd2aa14e7c129181191350f9a475
parent81a0b7b4b50e676782b0856cd19285eea94159c4 (diff)
community/osmin: upgrade to 1.12.2
-rw-r--r--community/osmin/APKBUILD19
-rw-r--r--community/osmin/cpp-locale.patch11
2 files changed, 8 insertions, 22 deletions
diff --git a/community/osmin/APKBUILD b/community/osmin/APKBUILD
index 8c726fd6828..72c90e82ade 100644
--- a/community/osmin/APKBUILD
+++ b/community/osmin/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Eloi Torrents <eloitor@disroot.org>
# Maintainer: Eloi Torrents <eloitor@disroot.org>
pkgname=osmin
-pkgver=1.9.7
+pkgver=1.12.2
pkgrel=0
-_libosmscout_version=1.9-20230212
pkgdesc="GPS Navigator On-Road/Off-Road"
url="https://github.com/janbar/osmin"
arch="all !armhf !s390x"
@@ -13,6 +12,7 @@ license="GPL-3.0-only"
makedepends="
clang
cmake
+ doxygen
gnu-libiconv-dev
libmarisa-dev
libxml2-dev
@@ -29,15 +29,13 @@ makedepends="
"
options="!check" # no test suite
source="$pkgname-$pkgver.tar.gz::https://github.com/janbar/osmin/archive/refs/tags/$pkgver.tar.gz
- $pkgname-osmscout-$pkgver.tar.gz::https://github.com/janbar/libosmscout/archive/refs/tags/osmin-$_libosmscout_version.tar.gz
+ $pkgname-osmscout-$pkgver.tar.gz::https://github.com/janbar/libosmscout/archive/refs/tags/osmin-$pkgver.tar.gz
system-libmarisa.patch
- cpp-locale.patch
- libxml2-2.12.patch
"
prepare() {
rmdir backend/libosmscout
- mv -v ../libosmscout-$pkgname-$_libosmscout_version backend/libosmscout
+ mv -v ../libosmscout-$pkgname-$pkgver backend/libosmscout
default_prepare
}
@@ -50,7 +48,8 @@ build() {
-DCMAKE_C_COMPILER=clang \
-DCMAKE_CXX_COMPILER=clang++ \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_DEPENDENCIES=OFF
+ -DBUILD_DEPENDENCIES=OFF \
+ -DBUILD_DEVICEMOBILE=ON
cmake --build build
}
@@ -59,9 +58,7 @@ package() {
}
sha512sums="
-facfb9fe3a437842be5a3d2b332549b0df6608717be98051a24e95e59e024276f853716bc6479e93abfbb868997bde97fd558943a8227dfc870b001dd40803da osmin-1.9.7.tar.gz
-f4a8628a7e8a267b5c81e3b9e92219538515add64ed343d6795e6d9b23947c560a3e151c5ecbb241052f20eda02d32b08ce85793038b651180339c6bf2e6af60 osmin-osmscout-1.9.7.tar.gz
+c0b8ff9072ec634664e7c309b496e3ca1ce3320e48aa86bbd293d2f6d0fcef63b40222410b5d8565f49eb5620e55dbb92116c774548ce7e854c7511e0311dce8 osmin-1.12.2.tar.gz
+55f5eb4d2e1fd61532b79ba037ca39274354988e71dae82c101466e1f6e030b32a438da12d20d9bedbd7e0427b1982db979ee63929a7820cc93cb1990f5f39b6 osmin-osmscout-1.12.2.tar.gz
034ac53631e1ba1dc8e6af4727664584e4adb015573ae632aaf12d73ea2b0eab1526b93a25c63cda497aec91486ec4cfe6ba0e9aa97227b59a168411b7dee5c7 system-libmarisa.patch
-9b80f943701d790b8b6ad012234c4e36f3a76b0ccb2ed34c62082fa81488cab9d737de97062cdc59d1a74ed6a9064347bc7115af2362111f73f64505640c04a2 cpp-locale.patch
-8e1af71260a5ff57c7797558ade715e832a4fe2283a1fd113249ba835ce7f9c3415b54df037459ff2e98aab875483b87b2605769f1bbf73ce38bf75feffd4efe libxml2-2.12.patch
"
diff --git a/community/osmin/cpp-locale.patch b/community/osmin/cpp-locale.patch
deleted file mode 100644
index 383827be515..00000000000
--- a/community/osmin/cpp-locale.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/backend/libosmscout/libosmscout/include/osmscout/util/Locale.h
-+++ b/backend/libosmscout/libosmscout/include/osmscout/util/Locale.h
-@@ -102,7 +102,7 @@
- }
-
- public:
-- static Locale ByEnvironment(std::locale locale = std::locale(""));
-+ static Locale ByEnvironment(std::locale locale = std::locale());
- };
- }
-