aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-11-09 09:10:50 +0000
committerpsykose <alice@ayaya.dev>2022-11-09 10:10:50 +0100
commit82359ed2f2cff05598bd300db0ec847c996fcc29 (patch)
treed0dac8eb35c01daa798a7b5d744b4ea33c4a3dae
parentce6f81df0382091a7b4dbf3c974b61f133e1291b (diff)
community/libnma: fix vpn and file conflict
-rw-r--r--community/libnma/APKBUILD10
-rw-r--r--community/libnma/fix-vpn.patch30
2 files changed, 38 insertions, 2 deletions
diff --git a/community/libnma/APKBUILD b/community/libnma/APKBUILD
index c375f096ced..27cc40e13a9 100644
--- a/community/libnma/APKBUILD
+++ b/community/libnma/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libnma
pkgver=1.10.4
-pkgrel=0
+pkgrel=1
pkgdesc="NetworkManager GUI client library"
url="https://wiki.gnome.org/Projects/NetworkManager/"
arch="all"
@@ -20,7 +20,9 @@ makedepends="
vala
"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/libnma/${pkgver%.*}/libnma-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/libnma/${pkgver%.*}/libnma-$pkgver.tar.xz
+ fix-vpn.patch
+ "
build() {
abuild-meson \
@@ -37,8 +39,12 @@ check() {
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ # in network-manager-applet
+ rm "$pkgdir"/usr/share/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
}
sha512sums="
4fe0d6b0e5b3c1bd7654e03dce747ee390de76d6641eb317fecb901ed6768bf48785e4a99e6fc8f12864066d06a64e308a8dbb2081a2d57e3f1509ca712deccc libnma-1.10.4.tar.xz
+3f8f49eabf4adcc13f39529b19d662d27b0fd7355faa6b1d8b6d7b9a4557a71ddbfb24c729ca60eddbbff68f10918b3e1f6415675198f7ae8435d550c1cbeaf4 fix-vpn.patch
"
diff --git a/community/libnma/fix-vpn.patch b/community/libnma/fix-vpn.patch
new file mode 100644
index 00000000000..9e3e4752783
--- /dev/null
+++ b/community/libnma/fix-vpn.patch
@@ -0,0 +1,30 @@
+Patch-Source: https://github.com/archlinux/svntogit-packages/blob/1e697b89392192e5a1a9c1188aa26791e3f0417a/trunk/0001-gschema-Remove-path-from-eap-schema.patch
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Wed, 9 Nov 2022 08:00:19 +0000
+Subject: [PATCH] gschema: Remove path from eap schema
+
+This one needs to be relocatable, otherwise creating a new VPN
+connection will fail with:
+
+ settings object created with schema 'org.gnome.nm-applet.eap'
+ and path '/org/gnome/nm-applet/eap/<uuid>/',
+ but path '/org/gnome/nm-applet/eap/' is specified by schema
+
+Fixes: https://bugs.archlinux.org/task/76490
+---
+ org.gnome.nm-applet.eap.gschema.xml.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/org.gnome.nm-applet.eap.gschema.xml.in b/org.gnome.nm-applet.eap.gschema.xml.in
+index 0fc3ca9f1f61..f4a56ea672cd 100644
+--- a/org.gnome.nm-applet.eap.gschema.xml.in
++++ b/org.gnome.nm-applet.eap.gschema.xml.in
+@@ -1,6 +1,6 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <schemalist>
+- <schema id="org.gnome.nm-applet.eap" path="/org/gnome/nm-applet/eap/" gettext-domain="nm-applet">
++ <schema id="org.gnome.nm-applet.eap" gettext-domain="nm-applet">
+ <key name="ignore-ca-cert" type="b">
+ <default>false</default>
+ <summary>Ignore CA certificate</summary>