aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Ahouansou <matthias@ahouansou.cz>2023-11-18 21:22:55 +0000
committeromni <omni+alpine@hack.org>2023-11-19 02:30:00 +0000
commit82436ad0ae8b1750bd639252929a9d6d8df5e0cc (patch)
tree3521b2fb289c36e20edbe0d8abb757684c472232
parentaafad8d5be8d5d6b3b7057c2b19fbe7d71ef366d (diff)
testing/tree-sitter-nix: new aport
-rw-r--r--testing/tree-sitter-nix/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/tree-sitter-nix/APKBUILD b/testing/tree-sitter-nix/APKBUILD
new file mode 100644
index 00000000000..ce107b7f426
--- /dev/null
+++ b/testing/tree-sitter-nix/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Matthias Ahouansou <matthias@ahouansou.cz>
+# Maintainer: Matthias Ahouansou <matthias@ahouansou.cz>
+pkgname=tree-sitter-nix
+pkgver=0_git20230713
+_gitrev=66e3e9ce9180ae08fc57372061006ef83f0abde7
+pkgrel=0
+pkgdesc="Nix grammar for tree-sitter"
+url="https://github.com/nix-community/tree-sitter-nix"
+arch="all"
+license="MIT"
+makedepends="tree-sitter-dev"
+subpackages="$pkgname-doc"
+install_if="tree-sitter-grammars"
+source="$pkgname-$_gitrev.tar.gz::https://github.com/nix-community/tree-sitter-nix/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$pkgname-$_gitrev"
+options="!check" # no tests for shared lib
+
+build() {
+ abuild-tree-sitter build
+}
+
+package() {
+ DESTDIR="$pkgdir" abuild-tree-sitter install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+9f2d3f44af8b0c4b17aae83112fdaa15e945e5cdd0938bc4f1043dfac762ba9d56e7e8f575d62dfbacc57447443cca7b9ff93ecc72721d393d25d3a2761891f9 tree-sitter-nix-66e3e9ce9180ae08fc57372061006ef83f0abde7.tar.gz
+"