aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-12-23 03:02:44 +0000
committerpsykose <alice@ayaya.dev>2022-12-23 13:33:01 +0100
commit8ae51716604747853e5bf24165dd6f0b05f88cd7 (patch)
tree988dab260fa5b61b157347cfbb7825342dba80b6
parent7d9d4893144f7f1a8f47ed75a94cd0939c4bd40c (diff)
community/gtk4.0: upgrade to 4.8.3
-rw-r--r--community/gtk4.0/APKBUILD8
-rw-r--r--community/gtk4.0/copy-paste-touch-events-pr-5143.patch51
2 files changed, 3 insertions, 56 deletions
diff --git a/community/gtk4.0/APKBUILD b/community/gtk4.0/APKBUILD
index 994962de0fa..3deac985406 100644
--- a/community/gtk4.0/APKBUILD
+++ b/community/gtk4.0/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=gtk4.0
-pkgver=4.8.2
+pkgver=4.8.3
pkgrel=0
pkgdesc="The GTK Toolkit (v4)"
url="https://www.gtk.org/"
@@ -56,8 +56,7 @@ makedepends="
vulkan-loader-dev
zlib-dev
"
-source="https://download.gnome.org/sources/gtk/${pkgver%.*}/gtk-$pkgver.tar.xz
- copy-paste-touch-events-pr-5143.patch"
+source="https://download.gnome.org/sources/gtk/${pkgver%.*}/gtk-$pkgver.tar.xz"
builddir="$srcdir/gtk-$pkgver"
build() {
@@ -120,6 +119,5 @@ lang() {
}
sha512sums="
-400cdde53a4b76a912f52b1300286b2198d47195902ccfc034fbc518be7bc4c5817fe6df6386d764c95686083eede2e4582cc555fb38b0bce455942ea6c5fcb5 gtk-4.8.2.tar.xz
-564340d376cf7dae5473af045bafb35d765e78109d585067c19e0d02c5966574332797c8eb8c9274e5c0eca7abc6c5bb7d8504aca02e6cceefe34613c37ca501 copy-paste-touch-events-pr-5143.patch
+56be0f5ce85a9cbbda4a5de53baeeb6b8cc527a5d34723ae5548759ec7c28f03d204b6b6758dffed02a9e226f3bfcd1f15971105c2f2f7be7cef22538be27754 gtk-4.8.3.tar.xz
"
diff --git a/community/gtk4.0/copy-paste-touch-events-pr-5143.patch b/community/gtk4.0/copy-paste-touch-events-pr-5143.patch
deleted file mode 100644
index 1ea7a25f286..00000000000
--- a/community/gtk4.0/copy-paste-touch-events-pr-5143.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From eeda25ab044ee9678c7b68bf580a4d3d7beb62da Mon Sep 17 00:00:00 2001
-From: Carlos Garnacho <carlosg@gnome.org>
-Date: Wed, 19 Oct 2022 12:46:09 +0200
-Subject: [PATCH] gdk/wayland: Use serial of the latest implicit grab available
-
-When getting the serial for primary/clipboard selections we used a
-function that largely relied on a GdkEvent being passed. We have
-another available function that looks up the most recent serial
-given the ongoing touch/tablet input as well.
-
-This is the second best, compared to actually knowing the
-input/device from the event that was received by the UI an triggered
-the clipboard operation, and is already in use in other places
-(e.g. window dragging). It is valid for these situations too.
-
-Closes: https://gitlab.gnome.org/GNOME/gtk/-/issues/5250
----
- gdk/wayland/gdkdevice-wayland.c | 2 +-
- gdk/wayland/gdkprimary-wayland.c | 3 ++-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/gdk/wayland/gdkdevice-wayland.c b/gdk/wayland/gdkdevice-wayland.c
-index 98e08ecb5f..c6a3bacaa8 100644
---- a/gdk/wayland/gdkdevice-wayland.c
-+++ b/gdk/wayland/gdkdevice-wayland.c
-@@ -5323,7 +5323,7 @@ gdk_wayland_device_set_selection (GdkDevice *gdk_device,
- g_return_if_fail (GDK_IS_WAYLAND_DEVICE (gdk_device));
-
- seat = GDK_WAYLAND_SEAT (gdk_device_get_seat (gdk_device));
-- serial = _gdk_wayland_seat_get_implicit_grab_serial (GDK_SEAT (seat), NULL);
-+ serial = _gdk_wayland_seat_get_last_implicit_grab_serial (seat, NULL);
- wl_data_device_set_selection (seat->data_device, source, serial);
- }
-
-diff --git a/gdk/wayland/gdkprimary-wayland.c b/gdk/wayland/gdkprimary-wayland.c
-index 6cef2f3968..b501deb66b 100644
---- a/gdk/wayland/gdkprimary-wayland.c
-+++ b/gdk/wayland/gdkprimary-wayland.c
-@@ -292,7 +292,8 @@ gdk_wayland_primary_claim (GdkClipboard *clipboard,
- }
-
- seat = gdk_display_get_default_seat (GDK_DISPLAY (wdisplay));
-- serial = _gdk_wayland_seat_get_implicit_grab_serial (seat, NULL);
-+ serial = _gdk_wayland_seat_get_last_implicit_grab_serial (GDK_WAYLAND_SEAT (seat),
-+ NULL);
- zwp_primary_selection_device_v1_set_selection (cb->primary_data_device,
- cb->source,
- serial);
---
-GitLab
-