aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2022-09-15 01:39:40 +0200
committerMichał Polański <michal@polanski.me>2022-09-15 02:05:50 +0200
commit8bb73e062d69f0851cd0e77bad34e8b24f55e58c (patch)
tree4183abfc83d595ebdd47fac1890abf3c1d39cac4
parentdff587b40859ff28b79c9dfc6c4b10f60833e8b7 (diff)
community/py3-cleo: upgrade to 1.0.0a5
-rw-r--r--community/py3-cleo/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/py3-cleo/APKBUILD b/community/py3-cleo/APKBUILD
index 1d9c2c76f5a..3162c0cfd08 100644
--- a/community/py3-cleo/APKBUILD
+++ b/community/py3-cleo/APKBUILD
@@ -2,18 +2,17 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-cleo
-_realname=cleo
-pkgver=0.8.1
-pkgrel=5
+pkgver=1.0.0a5
+pkgrel=0
pkgdesc="Python3 library to create beautiful and testable command-line interfaces"
url="https://github.com/python-poetry/cleo"
arch="noarch"
license="MIT"
-depends="python3 py3-pastel py3-pylev py3-clikit"
-checkdepends="py3-pytest py3-pytest-mock"
+depends="python3 py3-crashtest py3-pylev"
makedepends="py3-build py3-installer py3-poetry-core"
+checkdepends="py3-pytest py3-pytest-mock"
source="$pkgname-$pkgver.tar.gz::https://github.com/python-poetry/cleo/archive/refs/tags/$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/cleo-$pkgver"
build() {
# XXX: hack for poetry to not ignore files
@@ -22,16 +21,16 @@ build() {
check() {
python3 -m installer -d testenv \
- dist/cleo-$pkgver-py2.py3-none-any.whl
+ dist/cleo-$pkgver-py3-none-any.whl
local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/cleo-$pkgver-py2.py3-none-any.whl
+ dist/cleo-$pkgver-py3-none-any.whl
}
sha512sums="
-9cd470063db9866a526f0bb8619d772c585377d5b1a662e0f94bad9fb9c853598b176444ca1ac0fadec82992196c471646504d6a28d4dcd1171433b8d160be9c py3-cleo-0.8.1.tar.gz
+015620f82bc2bf6e4ed4b899cbc6f4e75459e8d12766f383e4043210ed3e5bb9b3b45319cb847f4ca0b1eead7984b79bbc4d6af846505c7595cb31dc999287ce py3-cleo-1.0.0a5.tar.gz
"