aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRejah Rehim <rejah@beaglesecuruty.com>2021-09-14 23:49:22 +0530
committerLeo <thinkabit.ukim@gmail.com>2021-09-14 21:39:09 +0000
commit989cc3fb5d9d1782fcf0a8e77fa3b0e84a141ca5 (patch)
tree2672b2126af66f7149db10b108677673eef0dde7
parent0a15b20f6253759878ee074572744f6d92bed166 (diff)
testing/py3-eradicate : new aport
https://github.com/myint/eradicate Removes commented-out code
-rw-r--r--testing/py3-eradicate/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-eradicate/APKBUILD b/testing/py3-eradicate/APKBUILD
new file mode 100644
index 00000000000..832a6b2f86d
--- /dev/null
+++ b/testing/py3-eradicate/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rejah Rehim <rejah@beaglesecurity.com>
+# Maintainer: Rejah Rehim <rejah@beaglesecurity.com>
+pkgname=py3-eradicate
+_pkgname=eradicate
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Removes commented-out code"
+options="!check" # no test suite
+url="https://github.com/myint/eradicate"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc"
+source="https://files.pythonhosted.org/packages/source/e/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 README.rst -t "$pkgdir"/usr/share/doc/"$pkgname"
+}
+
+sha512sums="
+ca786e128dc7a27d0070a8e4e888aaa79a989fd8c0de2d7fb528ab1e6f5d127a1778c6decf7a6d96be030d15065a021b23b1d51505fcdaf776af9bf4876d8028 eradicate-2.0.0.tar.gz
+"