aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız <orhunparmaksiz@gmail.com>2024-01-01 17:40:43 +0300
committeromni <omni+alpine@hack.org>2024-01-19 01:59:11 +0000
commit9a451c959e0bdd6f2c50720a10b545e635be25b5 (patch)
tree67e30c564a25453af8934ff5a23da51d3841a662
parentb2eec24e90989e68e59d96a82f18185b7953d632 (diff)
testing/cargo-run-bin: new aport
https://github.com/dustinblackman/cargo-run-bin Build, cache, and run CLI tools scoped in Cargo.toml testing/
-rw-r--r--testing/cargo-run-bin/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/cargo-run-bin/APKBUILD b/testing/cargo-run-bin/APKBUILD
new file mode 100644
index 00000000000..c024df9bf30
--- /dev/null
+++ b/testing/cargo-run-bin/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Orhun Parmaksız <orhunparmaksiz@gmail.com>
+# Maintainer: Orhun Parmaksız <orhunparmaksiz@gmail.com>
+pkgname=cargo-run-bin
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="Build, cache, and run CLI tools scoped in Cargo.toml"
+url="https://github.com/dustinblackman/cargo-run-bin"
+arch="all"
+license="MIT"
+makedepends="
+ cargo
+ cargo-auditable
+ "
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dustinblackman/cargo-run-bin/archive/v$pkgver.tar.gz"
+options="net"
+options="$options !check" # https://github.com/dustinblackman/cargo-run-bin/issues/18
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --release --frozen
+}
+
+check() {
+ cargo test --frozen
+}
+
+package() {
+ install -Dm 755 "target/release/cargo-bin" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+sha512sums="
+5a81437f15f99b145ed6be4c3943e50e8f8f8b40bb36dc8a37ea29d6e43bfb0cb928d77ba3db19d0d919b4a8f4cbd3296b996db0c2ce0c42397393269a017f5d cargo-run-bin-1.7.2.tar.gz
+"