aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormio <miyopan@e.email>2024-02-29 16:50:11 +0000
committerPatrycja Rosa <alpine@ptrcnull.me>2024-02-29 20:51:32 +0000
commit9fbc0d1ddf00068b7b601a4f8f98ef6e07aef30a (patch)
treeff99db486efc9a39bcde383c6ff6c87ef2b23ceb
parentfa887903586f04632c2bd1b0aba1fd385723020c (diff)
community/ibus-anthy: upgrade to 1.5.16
-rw-r--r--community/ibus-anthy/APKBUILD12
-rw-r--r--community/ibus-anthy/disable-pycotap.patch11
2 files changed, 19 insertions, 4 deletions
diff --git a/community/ibus-anthy/APKBUILD b/community/ibus-anthy/APKBUILD
index a0e61233cb3..f96669ff2e2 100644
--- a/community/ibus-anthy/APKBUILD
+++ b/community/ibus-anthy/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: mio <miyopan@e.email>
# Maintainer: mio <miyopan@e.email>
pkgname=ibus-anthy
-pkgver=1.5.15
-pkgrel=2
+pkgver=1.5.16
+pkgrel=0
pkgdesc="Japanese input method Anthy IMEngine for IBus Framework"
url="https://github.com/ibus/ibus-anthy"
arch="all !s390x" # ibus needs librsvg which isn't available on s390x
@@ -25,7 +25,10 @@ checkdepends="
libfaketime
sed
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ibus/ibus-anthy/archive/$pkgver.tar.gz"
+# Patch disables checking for optional checkdepends package not in repos
+source="$pkgname-$pkgver.tar.gz::https://github.com/ibus/ibus-anthy/archive/$pkgver.tar.gz
+ disable-pycotap.patch
+ "
subpackages="$pkgname-lang"
prepare() {
@@ -56,5 +59,6 @@ package() {
}
sha512sums="
-0acebb1b397f98d156ba9d6465bdb1025fb23a6b05b72c9b471827b45e22af55468b7674469f348712682446641c98d68f3d2aa339d2a1997a2df8c2bac45a7c ibus-anthy-1.5.15.tar.gz
+af782509c3a098864fc0327f0f1226b2f1b9890b36bf69c208ffe977fb07c1f71dea946e8ad4dc9b2cdd6c84252d34a8c8b17f855c6fa7320e3a58b7719e86c5 ibus-anthy-1.5.16.tar.gz
+a918038736e6ce4cc8a357c042cb7b4271970ae9e58d855f481c4cc06b436215732e194c700518baaacfa947b34e3ad7172795087d8287319cb0a6a974d25d32 disable-pycotap.patch
"
diff --git a/community/ibus-anthy/disable-pycotap.patch b/community/ibus-anthy/disable-pycotap.patch
new file mode 100644
index 00000000000..84013bdc114
--- /dev/null
+++ b/community/ibus-anthy/disable-pycotap.patch
@@ -0,0 +1,11 @@
+--- a/tests/test-build.sh
++++ b/tests/test-build.sh
+@@ -95,7 +95,7 @@
+ RUN_ARGS="$RUN_ARGS --force";
+ fi;
+
+- maybe_install_pycotap
++ # maybe_install_pycotap
+
+ if test ! -f $BUILDDIR/../data/$ANTHY_SCHEMA_FILE ; then
+ echo "Not found $BUILDDIR/../data/$ANTHY_SCHEMA_FILE";