aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nystrom <sam@samnystrom.dev>2024-02-04 10:05:40 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2024-02-05 20:22:54 +0000
commita81d29b51a9cd220e550c0f9c35a5c6de18fbbe8 (patch)
tree11419cb62538758076e00977275fdd00e0243731
parent64435d793ecb612c86df807eb9d280ec19c42eec (diff)
testing/libvmaf: new aport
-rw-r--r--testing/libvmaf/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libvmaf/APKBUILD b/testing/libvmaf/APKBUILD
new file mode 100644
index 00000000000..ab61f93c047
--- /dev/null
+++ b/testing/libvmaf/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Sam Nystrom <sam@samnystrom.dev>
+# Maintainer: Sam Nystrom <sam@samnystrom.dev>
+pkgname=libvmaf
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Perceptual video quality assessment based on multi-method fusion"
+url="https://github.com/Netflix/vmaf"
+arch="all"
+license="BSD-2-Clause-Patent"
+makedepends="meson nasm xxd"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Netflix/vmaf/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/vmaf-$pkgver/libvmaf"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+9e356bb274ce7d5d85a64d2a1a122ea9d267809edd83bb6e663fb348a1a46355882eb9044982bf679f03df7f93c6f66c9b0d9a94661979b2c722db30b21c4f32 libvmaf-3.0.0.tar.gz
+"