aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-11-15 20:24:34 +0100
committeralice <alice@ayaya.dev>2022-11-16 11:44:00 +0000
commitb23a7d96995853809d667ebe84c30188ce3b1215 (patch)
treea0706fb3eda73674a30f060d194e75510e16593d
parent17973e338cbc5b18c598dec52c65bf304cd92cd6 (diff)
community/py3-pyphen: upgrade to 0.13.1
-rw-r--r--community/py3-pyphen/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/py3-pyphen/APKBUILD b/community/py3-pyphen/APKBUILD
index f2c72cc78a3..6aeab8de8e4 100644
--- a/community/py3-pyphen/APKBUILD
+++ b/community/py3-pyphen/APKBUILD
@@ -2,22 +2,28 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-pyphen
_pkgname=Pyphen
-pkgver=0.12.0
-pkgrel=3
+pkgver=0.13.1
+pkgrel=0
pkgdesc="python-based dictionary hyphenator library"
url="https://www.pyphen.org"
arch="noarch"
license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
makedepends="py3-build py3-flit py3-installer py3-wheel"
-checkdepends="py3-pytest py3-pytest-cov py3-pytest-isort py3-pytest-flake8"
+checkdepends="py3-pytest py3-pytest-cov py3-pytest-isort py3-pytest-xdist"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-options="!check" # https://github.com/tholo/pytest-flake8/issues/87
replaces="py-pyphen" # Backwards compatibility
provides="py-pyphen=$pkgver-r$pkgrel" # Backwards compatibility
+prepare() {
+ default_prepare
+ # disable pytest-flake8
+ # https://github.com/tholo/pytest-flake8/issues/87
+ sed -i 's/--flake8//' pyproject.toml
+}
+
build() {
python3 -m build --no-isolation --wheel
}
@@ -32,5 +38,5 @@ package() {
}
sha512sums="
-abecf0773f59b7a757b47c6512f1bf8e98f4709b285f04cf235c085ab4767eb95deab8ede4b792d6f4a6156d47287f9f712cb658939ed5afc475644e282adbd3 Pyphen-0.12.0.tar.gz
+230aec57f0a2db11f30b15115e5ed59ce19aed60120de24783f58ef831854ad7e236ae1da086bca01f9a41cef24f8402d9e0bf9251f6d55c38aa624fd55d4a3b Pyphen-0.13.1.tar.gz
"