aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 17:15:42 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-12 15:30:05 +0000
commitb7b434955c8405dac65fcec3289185a5ecad40e1 (patch)
treec266f0f88836df37d76b7ce0bb7dbdc7aeac740a
parent99425adcfd98555ec8d2eff01f3626c65de19938 (diff)
main/fish: switch to python3
-rw-r--r--main/fish/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/main/fish/APKBUILD b/main/fish/APKBUILD
index 1e05c578840..be949f658a9 100644
--- a/main/fish/APKBUILD
+++ b/main/fish/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=fish
pkgver=3.0.2
-pkgrel=4
+pkgrel=5
pkgdesc="Modern interactive commandline shell"
url="http://www.fishshell.com"
arch="all"
@@ -13,7 +13,15 @@ makedepends="doxygen ncurses-dev ncurses pcre2-dev"
checkdepends="expect bash"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools::noarch"
-source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/fish-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ for f in $(find share/tools -type f -name '*.py'); do
+ sed -i -e '1{s@^#!.*@#!%{__python3}@}' "$f"
+ done
+}
build() {
cd "$builddir"
@@ -64,7 +72,7 @@ doc() {
tools() {
pkgdesc="$pkgdesc (tools)"
- depends="$pkgname python cmd:man"
+ depends="$pkgname python3 cmd:man"
mkdir -p "$subpkgdir"/usr/share/$pkgname
mv "$pkgdir"/usr/share/$pkgname/tools "$subpkgdir"/usr/share/$pkgname