aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-03-01 17:38:15 +0100
committeralice <alice@ayaya.dev>2022-03-02 13:03:31 +0000
commitb85abc61220294c744e88469dd12d4208666683d (patch)
treeb1d378f4ee306cee354a24fb65e4d8a3ed765f12
parent304d371ae328649f02cf52827d86b9d4eccaa780 (diff)
community/smartypants: new aport
-rw-r--r--community/smartypants/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/smartypants/APKBUILD b/community/smartypants/APKBUILD
new file mode 100644
index 00000000000..84c44424730
--- /dev/null
+++ b/community/smartypants/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=smartypants
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Translate plain ASCII punctuation characters into “smart” typographic punctuation HTML entities"
+url="https://github.com/leohemsted/smartypants.py"
+arch="noarch"
+license="BSD"
+depends="python3"
+makedepends="py3-setuptools py3-sphinx"
+subpackages="$pkgname-doc"
+source="https://github.com/leohemsted/smartypants.py/archive/v$pkgver/smartypants-$pkgver.tar.gz"
+builddir="$srcdir/smartypants.py-$pkgver"
+
+build() {
+ python3 setup.py build
+
+ make -C docs man
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 docs/_build/man/smartypants.1 "$pkgdir"/usr/share/man/man1/smartypants.1
+}
+
+sha512sums="
+d47a866a5478c3520251f87a93a468a5eea10318b24b2e8d4bc918d533b5a5789aa56d3a8d5fb8ccff9572fb63e5b6f2eafc44f93fb57a19e6621ebef5d64d9d smartypants-2.0.1.tar.gz
+"