aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-11 09:44:22 +0000
committerpsykose <alice@ayaya.dev>2023-06-11 11:45:11 +0200
commitd8d4590b25df2fb6edc7f72d183a47a5dac65572 (patch)
tree585e762bbf319b55e75305dea3764e5e99ea0410
parent914675fda3e73d8626294cf75ce135698bad40f0 (diff)
community/coturn: upgrade to 4.6.2
-rw-r--r--community/coturn/APKBUILD11
-rw-r--r--community/coturn/coturn-openssl3.patch13
-rw-r--r--community/coturn/remove-check_oauth-test.patch15
3 files changed, 3 insertions, 36 deletions
diff --git a/community/coturn/APKBUILD b/community/coturn/APKBUILD
index 6add9e217e0..ad89b014818 100644
--- a/community/coturn/APKBUILD
+++ b/community/coturn/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: wener <wenermail@gmail.com>
pkgname=coturn
-pkgver=4.6.1
-pkgrel=1
+pkgver=4.6.2
+pkgrel=0
pkgdesc="Free open source implementation of TURN and STUN Server"
url="https://github.com/coturn/coturn"
arch="all"
@@ -12,10 +12,7 @@ pkgusers="$pkgname"
pkggroups="$pkgname"
install="$pkgname.pre-install"
subpackages="$pkgname-openrc $pkgname-static $pkgname-dev $pkgname-doc"
-# https://github.com/coturn/coturn/issues/193
source="coturn-$pkgver.tar.gz::https://github.com/coturn/coturn/archive/$pkgver.tar.gz
- remove-check_oauth-test.patch
- coturn-openssl3.patch
turnserver.initd
"
@@ -50,8 +47,6 @@ package() {
}
sha512sums="
-7033e2221f1590035f87cb51b2ce53d9fc4831515b17a693b8a016c199b0e50e4c06f507f462f31b602730318103ea304dfbcbf598d763faa4b58b050cd1de62 coturn-4.6.1.tar.gz
-3ad78467a509ed5c3eeac8585e13b11d276700cf45a8829e398a39c2056690aa9a66c3d40b73e2ce5815ce3199177220fb24224430919f49a70031f12e7d8c95 remove-check_oauth-test.patch
-9ce088deb379129774ebfc34447045d9b0b30e12fafc1a0608e89b700b44019bdb45da583a2d535f12f8e3f2c4a0345497a40c51736aa62b145fa39e9b9ee57d coturn-openssl3.patch
+ab8457921952a00b34111c03f2e5a2a9035977566270fdf9c8b9b777346645a8b233574134c0ef1c3aa2cf84bd89fbc82648678144c68ac0dff1712ce503b731 coturn-4.6.2.tar.gz
e686dc752618b2da2f6127ab11c49767bfcf228edf458cefe2853093baa845adb2b3159e850db1721e7474c4938fb237dd12bdfd7fd4db2ee73fbd0cb19af17d turnserver.initd
"
diff --git a/community/coturn/coturn-openssl3.patch b/community/coturn/coturn-openssl3.patch
deleted file mode 100644
index 6bb64f88c07..00000000000
--- a/community/coturn/coturn-openssl3.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/client/ns_turn_msg.c b/src/client/ns_turn_msg.c
-index 549f379..c7c5fbd 100644
---- a/src/client/ns_turn_msg.c
-+++ b/src/client/ns_turn_msg.c
-@@ -256,7 +256,7 @@ int stun_produce_integrity_key_str(const uint8_t *uname, const uint8_t *realm, c
- #else
- unsigned int keylen = 0;
- EVP_MD_CTX *ctx = EVP_MD_CTX_new();
--#if defined EVP_MD_CTX_FLAG_NON_FIPS_ALLOW && ! defined(LIBRESSL_VERSION_NUMBER)
-+#ifdef FIPS_MODE
- if (FIPS_mode()) {
- EVP_MD_CTX_set_flags(ctx, EVP_MD_CTX_FLAG_NON_FIPS_ALLOW);
- }
diff --git a/community/coturn/remove-check_oauth-test.patch b/community/coturn/remove-check_oauth-test.patch
deleted file mode 100644
index 3d8e02ad291..00000000000
--- a/community/coturn/remove-check_oauth-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/coturn/coturn/issues/193
-
---- ./src/apps/rfc5769/rfc5769check.c.orig
-+++ ./src/apps/rfc5769/rfc5769check.c
-@@ -564,10 +564,5 @@
- }
- }
-
-- {
-- if(check_oauth()<0)
-- exit(-1);
-- }
--
- return 0;
- }