aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrassy Boykinov <kboykinov@teamcentrixx.com>2024-02-08 16:21:13 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2024-02-08 18:01:53 +0000
commite9d411e67e815ab0fcf1d00885cb55dd0f99e810 (patch)
tree0222d9166803994436eb13ba9b7b9512d104db1f
parent14ba4f0c44c9ecf289e0f64dd30023a1e46a585a (diff)
community/qemu: upgrade to 8.1.5
-rw-r--r--community/qemu/APKBUILD6
-rw-r--r--community/qemu/cpuinfo-ppc.patch36
2 files changed, 2 insertions, 40 deletions
diff --git a/community/qemu/APKBUILD b/community/qemu/APKBUILD
index 5080693ff92..55423842891 100644
--- a/community/qemu/APKBUILD
+++ b/community/qemu/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
-pkgver=8.1.4
+pkgver=8.1.5
pkgrel=0
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="https://qemu.org/"
@@ -216,7 +216,6 @@ source="https://wiki.qemu-project.org/download/qemu-$pkgver.tar.xz
lfs64.patch
mips-softfloat.patch
musl-initialise-msghdr.patch
- cpuinfo-ppc.patch
CVE-2021-20255.patch
@@ -582,7 +581,7 @@ bridgehelper() {
}
sha512sums="
-b67afcf6d58808b02d015438c60dc74067b409c723b2736e69e66ffa3ed80a71d51b941a53e2bb944aa90a5538d631bcbd287d833ea9a78e3dd64ce299cb47ca qemu-8.1.4.tar.xz
+1005e0602a763979c4d0ec6e79a390e4232dcc3d0b8461fe42856c58e54ad25a2079f3850d27023fce8a2b382b36e3baa7882b69d48cbb72002984c160241c92 qemu-8.1.5.tar.xz
b392f229e631d149d28eb952dcd507d9e5b6975cbba123fd3dab10860fa1936d5035d8e266926652acc1d7cde6874c440beccd33d729bf346769d2c138ebbc01 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
2c6b3b22877674f870958bb0c74ad85c814f01c98fb123142b1ce77d89adf5c08626e6eade7f627090a53b48f5cebe2a535547804345648cff91dd66f90c2d5b xattr_size_max.patch
7672a3518050f275219920f2cb088f6991ac810dba077856129d779fdf45a3e8c0302c8ca4aa58c0c38e44af80f56404006b3f250e4921fb364cd6fe7149e6ea MAP_SYNC-fix.patch
@@ -591,7 +590,6 @@ b392f229e631d149d28eb952dcd507d9e5b6975cbba123fd3dab10860fa1936d5035d8e266926652
d5b4626193fa9b7c687a649aa5ea37d8a74fd2e556a66a71e31af618a0990e144beae253b82b89efd8a798102bcab59cf1a61a76029afcdb0bc5ed58fb40493f lfs64.patch
8a8385dbf4a232adbd51be31d64b1e3ad2333eeb0de867555f995bf1b353ec530f85a25c8b33ce6b9572edfe4bb979a0645f14b839394d8bd47c9ffcd91509a2 mips-softfloat.patch
7a6340df8aa28811af20cd23b98ba95fc8072d4d4d3a2d497604386396892cf26716d0755821e47d02c8eded203133d7dde100537c117e2a047179e4f93883cf musl-initialise-msghdr.patch
-bd84398d2f9e476f7345ab96c4b269c48e502c4e369d80a3941a01741689863d25e39d6d0dd3b10c041f82ac19d2a98471f668eaaeaf4f4853a56f52fbbc71a5 cpuinfo-ppc.patch
25778c29c1f2bf40572125a7b39a01227e3165ed555add44de72a714e4b9d5a91b1504f69d0df55b4e178035813d4c3eca5be048d9afa5e3647d13df3e2f5a30 CVE-2021-20255.patch
d90c034cae3f9097466854ed1a9f32ab4b02089fcdf7320e8f4da13b2b1ff65067233f48809911485e4431d7ec1a22448b934121bc9522a2dc489009e87e2b1f qemu-guest-agent.confd
1cd24c2444c5935a763c501af2b0da31635aad9cf62e55416d6477fcec153cddbe7de205d99616def11b085e0dd366ba22463d2270f831d884edbc307c7864a6 qemu-guest-agent.initd
diff --git a/community/qemu/cpuinfo-ppc.patch b/community/qemu/cpuinfo-ppc.patch
deleted file mode 100644
index f7318fc47a9..00000000000
--- a/community/qemu/cpuinfo-ppc.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Upstream: https://gitlab.com/qemu-project/qemu/-/issues/1861
-
-diff --git a/util/cpuinfo-ppc.c b/util/cpuinfo-ppc.c
-index 7212afa..990e62e 100644
---- a/util/cpuinfo-ppc.c
-+++ b/util/cpuinfo-ppc.c
-@@ -6,10 +6,10 @@
- #include "qemu/osdep.h"
- #include "host/cpuinfo.h"
-
-+#include <asm/cputable.h>
- #ifdef CONFIG_GETAUXVAL
- # include <sys/auxv.h>
- #else
--# include <asm/cputable.h>
- # include "elf.h"
- #endif
-
-@@ -40,7 +40,7 @@ unsigned __attribute__((constructor)) cpuinfo_init(void)
- info |= CPUINFO_V2_06;
- }
-
-- if (hwcap2 & PPC_FEATURE2_HAS_ISEL) {
-+ if (hwcap2 & PPC_FEATURE2_ISEL) {
- info |= CPUINFO_ISEL;
- }
- if (hwcap & PPC_FEATURE_HAS_ALTIVEC) {
-@@ -53,7 +53,7 @@ unsigned __attribute__((constructor)) cpuinfo_init(void)
- * always have both anyway, since VSX came with Power7
- * and crypto came with Power8.
- */
-- if (hwcap2 & PPC_FEATURE2_HAS_VEC_CRYPTO) {
-+ if (hwcap2 & PPC_FEATURE2_VEC_CRYPTO) {
- info |= CPUINFO_CRYPTO;
- }
- }