aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2024-04-26 13:29:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-30 08:04:15 +0000
commited0d367ad71ca942936a332b2d7cec4d5c5d694b (patch)
tree281a062e048800d36c830d14b85d20340ac479d6
parentb1df862e4e95d3a7cb78276bf845f3379a36bb5d (diff)
community/abiword: rebuild against boost 1.84
- change url, this is the listed one at wikipedia - add libxml2-2.12.patch from new upstream, source https://gitlab.gnome.org/World/AbiWord/-/commit/2a06be6a10a0718f8a3d8e00c317f5042c99a467
-rw-r--r--community/abiword/APKBUILD7
-rw-r--r--community/abiword/libxml2-2.12.patch29
2 files changed, 33 insertions, 3 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index 6aa9d51cb6b..338412b239d 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.5
-pkgrel=10
+pkgrel=11
pkgdesc="A fully-featured word processor"
-url="https://www.abisource.com/"
+url="https://gitlab.gnome.org/World/AbiWord"
arch="all"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
@@ -46,10 +46,10 @@ for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:_plugin"
done
-#source="https://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/abiword/abiword-$pkgver.tar.gz
enchant.patch
musl-1.2.3.patch
+ libxml2-2.12.patch
"
prepare() {
@@ -104,4 +104,5 @@ sha512sums="
a2484268901ff47307c9d1f1928622e364f1006f22ce38257c585144df9411dfe3c2dea28c1f1f50a6e545e8cc579cce34117a89dfa771e20312e3ea1a9989d6 abiword-3.0.5.tar.gz
16f28eafdd1c1444dec5b3f8cbdd00f12c6178ba8db5bb94196064653cdada4cb8e4b2ac78ee9a7093c7968c0ddeb9f50a4e6209a5d5836a24b1b2f1941fb576 enchant.patch
a4ee1de8df01a6570eb4d069a1b1abd38c39181020f862ce632ab5b863650a58fcaeadc4c988e7fcae3aade5841399d3d5d482d280d44a48286c24e3701e7969 musl-1.2.3.patch
+0f98383e160782ccc2160e1bd9f5ba5ca02463dc14c2caeb987f225c06b4484a3618a068ff35806b6e3b6b2748e90a558c71ffb8d44c669f302fdcaebca836d4 libxml2-2.12.patch
"
diff --git a/community/abiword/libxml2-2.12.patch b/community/abiword/libxml2-2.12.patch
new file mode 100644
index 00000000000..2c364224898
--- /dev/null
+++ b/community/abiword/libxml2-2.12.patch
@@ -0,0 +1,29 @@
+From 2a06be6a10a0718f8a3d8e00c317f5042c99a467 Mon Sep 17 00:00:00 2001
+From: Jan Tojnar <jtojnar@gmail.com>
+Date: Mon, 11 Dec 2023 01:55:53 +0100
+Subject: [PATCH] Fix build with libxml2 2.12
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+libxml 2.12.0 restructured headers so that xmlFree is no longer in the scope.
+Let’s add the correct include.
+---
+ src/af/util/xp/ut_stringbuf.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/af/util/xp/ut_stringbuf.cpp b/src/af/util/xp/ut_stringbuf.cpp
+index f1e8d9078..88488ad67 100644
+--- a/src/af/util/xp/ut_stringbuf.cpp
++++ b/src/af/util/xp/ut_stringbuf.cpp
+@@ -26,6 +26,7 @@
+ #include <algorithm>
+
+ #include <libxml/uri.h>
++#include <libxml/xmlmemory.h>
+
+ #include <glib.h>
+
+--
+GitLab
+