aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-03-27 08:03:32 +0000
committeromni <omni+alpine@hack.org>2024-04-02 02:35:24 +0000
commit85bf49c5a5a5c24b53365981fbd63ad77ee4b0c4 (patch)
treec31d5262c0430ecb09756039f1821e2bc8c1e3ac
parent26674b520a91a188e7a0eab62d0a40efea6ee6f3 (diff)
testing/emacs-pyim-cangjiedict: new aport
https://github.com/con5tella/pyim-cangjiedict Cangjie dicts for Emacs-pyim
-rw-r--r--testing/emacs-pyim-cangjiedict/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/emacs-pyim-cangjiedict/APKBUILD b/testing/emacs-pyim-cangjiedict/APKBUILD
new file mode 100644
index 00000000000..41f613e8bea
--- /dev/null
+++ b/testing/emacs-pyim-cangjiedict/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=emacs-pyim-cangjiedict
+pkgver=0_git20210617
+_gitrev=d17e3d32a6480939b350a91a915ebe8e6efad819
+pkgrel=0
+_pkgreal=pyim-cangjiedict
+pkgdesc="Cangjie dicts for Emacs-pyim"
+url="https://github.com/con5tella/pyim-cangjiedict"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="cmd:emacs"
+makedepends="emacs-nox emacs-pyim"
+source="https://github.com/con5tella/pyim-cangjiedict/archive/$_gitrev/emacs-pyim-cangjiedict-$_gitrev.tar.gz"
+builddir="$srcdir/$_pkgreal-$_gitrev"
+options="!check" # no tests provided
+
+build() {
+ emacs -batch -q -no-site-file -L . \
+ -eval '(setq byte-compile-error-on-warn t)' \
+ -f batch-byte-compile \
+ ./*.el
+}
+
+package() {
+ install -Dvm644 ./*.el ./*.elc ./*.pyim \
+ -t "$pkgdir"/usr/share/emacs/site-lisp/pyim/
+
+ cd "$pkgdir"/usr/share/emacs/site-lisp/pyim
+ emacs -batch -q -no-site-file \
+ -eval "(loaddefs-generate \".\" \"$_pkgreal-loaddefs.el\")"
+}
+
+sha512sums="
+eed4416458f82f93ac8388046a4634bb719deafbe4a23cbe3f5e5c16546d62b3892a3cda6b0deca16889c403b4088dc196ba19e6cf60138315285fa01e5fe78d emacs-pyim-cangjiedict-d17e3d32a6480939b350a91a915ebe8e6efad819.tar.gz
+"