aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Zakharchenko <dmitz@disroot.org>2022-10-09 19:12:58 +0300
committerpsykose <alice@ayaya.dev>2022-10-11 01:21:34 +0200
commita64c94ebb016f9fb0416603a55e3daba2da0a8f6 (patch)
tree77637ec03a1419db2cc7e1fcf63a6c9f264f462e
parent4d277d1b75dca2258eb984b0cd1ed9f1de7da050 (diff)
community/py3-tzdata: new aport
-rw-r--r--community/py3-tzdata/APKBUILD36
-rw-r--r--community/py3-tzdata/masonry.patch10
2 files changed, 46 insertions, 0 deletions
diff --git a/community/py3-tzdata/APKBUILD b/community/py3-tzdata/APKBUILD
new file mode 100644
index 00000000000..2c002189d39
--- /dev/null
+++ b/community/py3-tzdata/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Dmitry Zakharchenko <dmitz@disroot.org>
+# Maintainer: Dmitry Zakharchenko <dmitz@disroot.org>
+pkgname=py3-tzdata
+_pkgname=pytzdata
+pkgver=2020.1
+pkgrel=0
+pkgdesc="Olson timezone database for Python"
+url="https://github.com/sdispater/pytzdata"
+arch="noarch"
+license="MIT"
+depends="python3 tzdata"
+makedepends="py3-build py3-installer py3-poetry-core"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sdispater/$_pkgname/archive/$pkgver.tar.gz
+ masonry.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ GIT_DIR=. \
+ python3 -m build --no-isolation --wheel
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ dist/$_pkgname-$pkgver-py2.py3-none-any.whl
+}
+
+sha512sums="
+fd154bfbe90ce07a90f769063b772234036d2627c1e6d78a465d9ddbc894e50cb9d821c04ebff1a7cc6a327266f7843fe54e5592d37c41db023329d6e0f668c2 py3-tzdata-2020.1.tar.gz
+8724c71912f857e05e749d6fd9ed5015f1de9a67b66c57c26918d9b5203780d5fbca37b5d0367483481af9197d1cefdea43119bc4989af0bca17920a691228ce masonry.patch
+"
diff --git a/community/py3-tzdata/masonry.patch b/community/py3-tzdata/masonry.patch
new file mode 100644
index 00000000000..e0835f2e026
--- /dev/null
+++ b/community/py3-tzdata/masonry.patch
@@ -0,0 +1,10 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -30,5 +30,5 @@ black = {version = "^18.9b0", python = "^3.6"}
+
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry_core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"